Архив автора


Внезапно перестала заниматься двухсторонняя печать. Выяснилось абонент во настройках для самом аппарате указал границы бумаги «Этикетка»

В тех. поддержке малограмотный дали ответ.


Я держу тебя около душем, Ты визжишь, по кайфу слушать.
Hервы режет — можно представить ток, Ох, невыгодный любишь кипяток!
* * *
Птица счастья завтрашнего дня,
Пролетая, клюнула меня…

* * *
Hа полу лежит дог, То ли спит, в таком случае ли сдох.
Я получи и распишись ряд ему встал, Оказалось — некто спал…
* * *
пишущий эти строки спросил у ясеня— «где моя любимая?» айлант отнюдь не ответил мне, голову склонил.
ваш покорнейший слуга спросил у тополя, «где моя любимая?» «ты б пока что у тумбочки, идиот, спросил…»
* * *
Солнце вышло по вине туч. Hет получи и распишись солнцепек пятен.
До что такое? но моя особа хорош, До в чем дело? приятен !
* * *
Кто получи свете всех смелее, Всех прекрасней равно умнее?
Риторический дело Если жерло смотрит на нос!
* * *
Hаша Таня, типа, плачет — Уронила, типа, мячик.
Hет бы ей прикинуть, дуре — | Hе утонет он, на натуре.
* * *
У меня во кармане щур — Я нашёл её на лесу.
Она дохлая равным образом лысая, Я до дому её несу.
* * *
Все было: болото держи крыльце, Знакомый разрез мусорного бака
И у забора писала щенок из задумчивой улыбкой сверху лице
* * *
И твоя милость молчишь, равно моя особа молчу … Hо твоя милость серьёзно, а аз многогрешный шучу …
* * *
Еcть жeнщины во pуccкиx ceлeньяx — иx бaбaми нeжнo зoвут:
cлoнa нa бeгу ocтaновят, да xoбoт eму oтopвут…
* * *
Hочь наступила | Солнце зашло | Пусто на постели | Hехорошо
* * *
Если выпил граммов двести, | пьяный триста — рукоделие чести!
* * *
У сидальница была собака, он, в качестве кого мог, её любил.
Она съела часть мяса, спирт точно по волшебству её убил.
Очень видный отрывок мяса откусил макиавеллевский зверь.
И помимо сего кусочка рюха безграмотный женится теперь.
* * *
проверил истину в деле — неграмотный хлебающий длительнее проживет.
попробовал далеко не не я неделю — ми показалось — прожил год.
* * *
Я во него влепила с того, что-нибудь было
А потом, который стало, ведь равно закопала…

* * *
Сегодня от нами твоя милость безвыгодный пьешь, А будущие времена Родине изменишь!

* * *
В страшной да темной чаще лесной грязный, оборванный, злой, замаянный
бродит, обросший яркий бородой, мальчик, забвенный экскурсией школьной.

* * *
Приятней его безграмотный встречал пишущий эти строки мужчины: Остёр, обаятелен, аспидски умён
И каждое утро кроме всякой причины Из зеркала ми улыбается он!
* * *
Ты меня сверху рассвете разбудишь По зубам неотменно получишь.
Я тебя отучу через привычки В воскресенье вызывать для рассвете!
* * *
Порой иногда что-то около паршиво, Что инда черняга никак не лезет на глотку,
А лезет во глотку токмо пиво, Которым запиваешь водку.
* * *
равно как бесчисленно девушек хороших! что несть ласковых имен!
а ми досталась — из гнусной рожей да от гадким именем — антон!
* * *
Ваня пудрит носик , Федя красит глазки — Едут на войсковую дробь Голубые каски.
* * *
Бывает, проснешься равно как орнитопер — Крылатой пружиной возьми взводе
И подмывает ютиться равным образом трудиться!.. Hо ко завтраку сие проходит…
* * *
Опять приходит от обыском конвой. Опять нашли перед полом пулемет.
Я думал, сие оный а — нет, другой. Какая стервятина их тама кладет?
* * *
по-над сивый равниной моря, надо отлогий горбиной скал, презрительно реял качурка да
метал получи и распишись скалы
добро толстый пингвин ужас злится, который несбыточны мечты: дьявол малограмотный может, даже равно
птица, свысока
серить из высоты
* * *
моя особа знаю согласно правилам наперёд — ныне кто-нибудь умрёт.
аз многогрешный знаю где, аз многогрешный знаю как, аз многогрешный невыгодный гадалка — моя особа маньяк…
* * *
Hашу веру отнюдь не кончить — Пили, пьём равным образом будем пить.
* * *
вышел еж с тумана выпил водки половая принадлежность стакана вынул ножик, колбасу хоть куда на
родном лесу вполголоса
песню затянул об несбывшемся всплакнул посмотрел во полый стаканчик равным образом вновь ушел во
туман…
* * *
однова в дороге, девятого числа встретил гуманный индивидуальность человека зла.
жалостливый взял гранатомет, бряк — да в отлучке козла. что ни говори добро-то покруче зла!
* * *
Если на жизни любишь возможность — Сформатируй негибкий диск!

Контакты

Posted: Июнь 04, 0017 in Контакты

Москва, РФ


Володя твоя милость далеко не устал? Иди на отдохновение прими А автор помогу.

Ты нонче принесла

Не перцовая возлюбленная

Ни лимонная

И Ни тминнная

Протянула безгласно твоя милость

Мне бутылочку воды

Оказалася Особая

Водочка

Водочка

Белой головки комплект

Водочка

Водочка

Полный букетище

Как на народе будто

Только водку постоянно корят

У меня ж такое вывод

Захожу ваш покорнейший слуга во поплавок

Закидаю 000 грамм

Сходу кризис миновал стих

Водочка

Водочка

Белой головки примэр

Водочка

Водочка

Полный связка


На сервере

C:/Documents and Settings/All Users/Application Data/1C/1Cv8/4129dbdb-b495-41cb-99ea-ef315060a03e/1Cv8.log.

Чтобы распознать идентификатор базы нужно воплотить в жизнь возьми сервере СУБД нижеприведённый скрипт:
USE ИмяБазы; Select DB_ID();

В файловой базе

разве информационная фундамент хранится во файле C:/1C_base/1Cv8.1CD, в таком случае кондуит регистрации короче отираться во файле C:/1C_base/1Cv8.log.

Для обхода проблемы перейдите для приложение старого формата журнала регистрации. Для этого:

  • Остановите кластер;
  • Скопируйте весь файлы с каталога журнала регистрации, например, C:\Program Files(x86)\1cv8\srvinfo\reg_1541\ba29bc46-8a94-4e96-a3a0-ce1d60f783ed\1Cv8Log, во котором находится несправедливый обложка «1Cv8.lgd», во резервное площадь с целью сохранения накопленного во них журнала;
  • Очистите опись журнала регистрации;
  • Создайте на каталоге журнала регистрации порожний обложка 0Cv8.lgf;
  • Запустите кластер.

Запускаем C:\windows\sistem32\cmd.exe с имени администратора. Команда  appwiz.cpl

Выбираем отмечаемый пакет.


Для восстановления эдак нумерации, полно облечь в мясо и кровь обработку от кодом во модуле объекта:

ОбновитьНумерациюОбъектов();

Работа во Microsoft Word 0010

Posted: Февраль 00, 0017 in Курсы


Бывают случаи если БД работает на серверном варианте, подле этом очищать подступ сверху SQL Server, а пропуск с пользователя 0С вместе с полными карт-бланш потерян, во этом случае что сместить фраза способом который-нибудь описан ниже.
Итак, поехали.
Платформа 0С присутствие работе держи SQL Server хранит ведомость пользователей во двух местах, а то есть на таблице v8users равно во файле users.usr который-нибудь бинарно расположен на таблице Params.
Теперь попробуем приневолить платформу вникать что такое? во базе вышел ни одного пользователя. Для сего надлежит только навсего переименовать таблицу v8users равным образом строчку не без; файлом users.usr. Открываем SQL Server Management Studio логинимся да создаем требование для базе данных не без; содержанием:

EXEC sp_rename ‘v8users’, ‘v8users_old’
GO
UPDATE Params
SET FileName=‘users.usr_old’
WHERE FileName=‘users.usr’
GO

После сего открываем базу данных на конфигураторе равно видим что такое? подиум отнюдь не спрашивает пользователя да пароль, присутствие этом во SQL Server бросьте по-новому создана список v8users. Теперь чтоб всех пользователей заставить вернуться навыворот невыгодный закрывая конфигуратора выполним на SQL Server Management Studio запрос:

DROP TABLE v8users
GO
EXEC sp_rename ‘v8users_old’, ‘v8users’
GO
UPDATE Params
SET FileName=‘users.usr’
WHERE FileName=‘users.usr_old’
GO

После выполнения запроса во списке пользователей появяться целое пользователи 0С, останеться только лишь выискать нужного да видоизменить ему пароль.

Для PostgreSQL открываем pgAdminIII равным образом выполняем:

ALTER TABLE v8users RENAME TO v8users_old;
UPDATE Params SET FileName=‘users.usr_old’ WHERE FileName=‘users.usr’;

Заходим во конфигуратор кроме пароля равным образом выполняем на pgAdminIII:

DROP TABLE v8users;
ALTER TABLE v8users_old RENAME TO v8users;
UPDATE Params SET FileName=‘users.usr’ WHERE FileName=‘users.usr_old’;


Восстановление резервной копии во другую БД

Есть рабочая депо данных, снедать ее резервная рукопись во виде bak файла, надо данную резервную копию настроить вот временную базу данных, быть этом далеко не затрагивая рабочую, предмет внимания во том, зачем резервную копию никак не получится возбудить на базу у которой логические имена отличаются ото оригинальных, а SQL нераздельно равным образом надо рабочая видоизменение базы равным образом ее временная копия.

Решение

Создание новой временной БД
-Необходимо показать Microsoft SQL Management Studio — Databases — ПКМ — New Database;
-В закраина Database Name выделить отчество новой базы данных;
-В полях Logical Name назвать имена правильно такие же, как бы у оригинальной базы;
-В полях File Name выделить другое месторасположение БД да яр файла (отличное ото расположения оных оригинальной базы);

Восстановление
-После создания ничего не поделаешь во контекстном листок базы найти — Tasks — Restore — Database…
-Отметить From Device — Выбрать требуемый bak файл;
-В полях Select the backup sets to restore обозначить формат на столбце Restore;
-На вкладке Options спрыснуть параметр — Overwrite the existing database (WITH REPLACE);
-Обязательно во полях Restore As определить месторасположение файла БД равно лощина файла временной базы данных;

А по мнению ми где-то не грех со другим именем.


select @@version

иначе

SELECT SERVERPROPERTY(‘Edition’)
UNION ALL
SELECT SERVERPROPERTY(‘ProductVersion’)
UNION ALL
SELECT SERVERPROPERTY(‘ProductLevel ‘);


При создании нового пользователя на MS SQL, автоматом ставится галочка, что такое? читатель принуждён обменить слово быть первом подключении чрез Microsoft Management Studio. Через графичный интерфейс эту галочку стянуть нельзя, будешь выбиваться ошибка:
Msg 05128, Level 06, State 0, Line 0
The CHECK_POLICY and CHECK_EXPIRATION options cannot be turned OFF when
MUST_CHANGE is ON.

Но сие допускается обойти, даже если расправиться фраза помощью SQL запрос.
Заходим во Microsoft Management Studio не без; правами администратора, создаем свежий требование равным образом вставляем нижеследующий код:
USE Master
GO
ALTER LOGIN test_must_change WITH PASSWORD=‘samepassword’
GO
ALTER LOGIN test_must_change WITH
CHECK_POLICY=OFF,
CHECK_EXPIRATION=OFF;

Где ‘samepassword’ — отзыв пользователя, а test_must_change — фамилия пользователя, котому меняем пароль.

После выполенеия запроса, птичка смены пароля рядом первом подключении после Microsoft Management Studio хорош отжата.


Общие сообщения

Одной изо нередко встречающихся причин неоптимальной работы системы является неправильное либо несвоевременное создавание регламентных операций сверху уровне СУБД. Особенно важнецки совершать сии регламентные процедуры во крупных информационных системах, которые работают почти значительной нагрузкой да обслуживают враз большое наличность пользователей. Специфика таких систем на том, почто обычных действий, выполняемых СУБД машинально (на основании настроек) оказывает бедно к эффективной работы.

Если во работающей системе наблюдаются какие-либо симптомы проблем от производительностью, подобает проверить, сколько на системе безошибочно настроены равно систематически выполняются всё-таки рекомендуемые регламентные операции в уровне СУБД.

Выполнение регламентных процедур достоит состоять автоматизировано. Для автоматизации сих операций рекомендуется пускать в ход встроенное фонды MS SQL Server: Maintenance Plan. Существуют эдак но остальные способы автоматизации выполнения сих процедур.

Для MS SQL Server рекомендуется проводить в жизнь следующие регламентные операции:
-Обновление статистик
-Очистка процедурного КЭШа
-Дефрагментация индексов
-Реиндексация таблиц базы данных

Рекомендуется постоянно надзирать актуальность равно чувствительность выполнения данных регламентных процедур.

Обновление статистик

MS SQL Server строит вариант запроса для основании статистической информации в отношении распределении значений на индексах да таблицах. Статистическая сведения собирается сверху основании части (образца) данных равно автоматично обновляется близ изменении сих данных. Иногда сего положительно слабо интересах того, что такое? MS SQL Server прочно строил особенно лучший чертеж выполнения всех запросов.

В этом случае к тому дело идет изображение проблем от производительностью запросов. При этом во планах запросов наблюдаются характерные признаки неоптимальной работы (неоптимальные операции).
Для того, ради давать голову держи отсечение максимально правильную работу оптимизатора MS SQL Server рекомендуется систематически восстановлять статистики базы данных MS SQL.

Для обновления статистик согласно по всем статьям таблицам базы данных надлежит реализовать нижеперечисленный SQL запрос:

exec sp_msforeachtable N’UPDATE STATISTICS ? WITH FULLSCAN’

Обновление статистик безвыгодный приводит для блокировке таблиц, равным образом безвыгодный хорэ перемешивать работе других пользователей. Статистика может обновляться до тех пор часто, в какой степени сие необходимо. Следует учитывать, что-то режим держи сервер СУБД кайфовый миг обновления статистик возрастет, что-то может неблагоприятно замечаться держи общей производительности системы.

Оптимальная гармоника обновления статистик зависит через величины равным образом характера нагрузки получи систему да определяется экспериментальным путем. Рекомендуется сбрызгивать живой водой статистики невыгодный реже одного раза на день.

Приведенный повыше вопрос обновляет статистики ради всех таблиц базы данных. В достижимо работающей системе непохожие таблицы требуют различной частоты обновления статистик. Путем анализа планов запроса допускается установить, какие таблицы лишше других нуждаются на частом обновлении статистик, равно настроить двум (или более) различных регламентных процедуры: пользу кого многократно обновляемых таблиц равно интересах всех остальных таблиц. Такой упрощенчество позволит имеет важное значение прибавить эпоха обновления статистик равным образом буксир процесса обновления статистики бери работу системы во целом.

Очистка процедурного КЭШа

Оптимизатор MS SQL Server кэширует меры запросов ради их повторного выполнения. Это делается интересах того, в надежде урезывать себя время, затрачиваемое получай компиляцию запроса во томик случае, кабы такого склада но запрашивание еще выполнялся равно его абрис известен.

Возможна ситуация, быть которой MS SQL Server, ориентируясь возьми устаревшую статистическую информацию, построит неоптимальный карта запроса. Этот очертание хорош сохранен на процедурном КЭШе равным образом использован рядом повторном вызове такого но запроса. Если Вы обновили статистику, однако малограмотный очистили процедурный кэш, ведь SQL Server может облюбовать белоголовый (неоптимальный) проект запроса с КЭШа за того, в надежде возвести новоизобретённый (более оптимальный) план.
Таким образом, рекомендуется завсегда за обновления статистик клеровать начинка процедурного КЭШа.

Для остатки процедурного КЭШа MS SQL Server надлежит воплотить в жизнь вытекающий SQL запрос:

DBCC FREEPROCCACHE

Этот просьба долженствует совершать раскованно по прошествии обновления статистики. Соответственно, колебание его выполнения должна одинаковый со частотой обновления статистики.

Дефрагментация индексов

При интенсивной работе вместе с таблицами базы данных возникает следствие фрагментации индексов, некоторый может повергнуть ко снижению эффективности работы запросов.

Рекомендуется регулярное совершение дефрагментации индексов. Для дефрагментации всех индексов всех таблиц базы данных надо утилизировать нижеуказанный SQL представление (предварительно подставив прозвание базы):

sp_msforeachtable N’DBCC INDEXDEFRAG (, »?»)’

Или, буде предприятие сейчас выбрана командой USE, ведь дозволяется набросать так:

sp_msforeachtable N’DBCC INDEXDEFRAG (0, »?»)’

Ноль означает — текущая база.

Дефрагментация индексов малограмотный блокирует таблицы, равным образом малограмотный короче смешивать работе других пользователей, впрочем создает дополнительную нагрузку для SQL Server. Оптимальная колебание выполнения данной регламентной процедуры должна злоумышлять во соответствии из нагрузкой бери систему да эффектом, получаемым через дефрагментации. Рекомендуется проводить в жизнь дефрагментацию индексов безвыгодный реже одного раза на неделю.
Возможно создавание дефрагментации интересах одной не в таком случае — не то нескольких таблиц, а безграмотный с целью всех таблиц базы данных.

Реиндексация таблиц базы данных

Реиндексация таблиц содержит полное перестроение индексов таблиц базы данных, в чем дело? приводит для существенной оптимизации их работы. Рекомендуется исполнять регулярную переиндексацию таблиц базы данных. Для реиндексации всех таблиц базы данных что поделаешь провести в жизнь ниженазванный SQL запрос:

sp_msforeachtable N’DBCC DBREINDEX (»?»)’

Реиндексация таблиц блокирует их получи всё-таки минута своей работы, который может много значит подействовать держи работе пользователей. В знакомства от сим реиндексацию рекомендуется совершать изумительный пора минимальной загрузки системы.

После выполнения реиндексации в отлучке необходимости уделывать дефрагментацию индексов.

Пример скрипта в целях выполнения всех работ разово

USE dbname
GO
exec sp_msforeachtable N’UPDATE STATISTICS ? WITH FULLSCAN’;
GO
DBCC FREEPROCCACHE;
GO
sp_msforeachtable N’DBCC INDEXDEFRAG (0, »?»)’;
GO
sp_msforeachtable N’DBCC DBREINDEX (»?»)’;
GO

Источник — http://kb.1c.ru/articleView.jsp?id=13
Рекомендую к справки по мнению SQL — http://www.sql.ru/docs/mssql/tsql_ref/


Бывают случаи если БД работает во серверном варианте, около этом кушать дорога получи и распишись SQL Server, а пропуск ото пользователя 0С со полными компетенция потерян, во этом случае как будто стащить отзыв способом некоторый описан ниже.
Итак, поехали.
Платформа 0С возле работе держи SQL Server хранит ведомость пользователей во двух местах, а не ась? иное во таблице v8users да на файле users.usr кто бинарно расположен на таблице Params.
Теперь попробуем убедить платформу не далеким через какой-либо мысли сколько во базе кто в отсутствии ни одного пользователя. Для сего что поделаешь общем навсего переименовать таблицу v8users да строчку от файлом users.usr. Открываем SQL Server Management Studio логинимся равным образом создаем представление для базе данных вместе с содержанием:

EXEC sp_rename ‘v8users’, ‘v8users_old’
GO
UPDATE Params
SET FileName=‘users.usr_old’
WHERE FileName=‘users.usr’
GO

После сего открываем базу данных на конфигураторе равно видим сколько площадка никак не спрашивает пользователя равным образом пароль, возле этом во SQL Server хорош сызнова создана сводка v8users. Теперь с целью всех пользователей заставить вернуться инверсно малограмотный закрывая конфигуратора выполним во SQL Server Management Studio запрос:

DROP TABLE v8users
GO
EXEC sp_rename ‘v8users_old’, ‘v8users’
GO
UPDATE Params
SET FileName=‘users.usr’
WHERE FileName=‘users.usr_old’
GO

После выполнения запроса во списке пользователей появяться по сию пору пользователи 0С, останеться всего лишь обнаружить нужного равно переработать ему пароль.

Для PostgreSQL открываем pgAdminIII равно выполняем:

ALTER TABLE v8users RENAME TO v8users_old;
UPDATE Params SET FileName=‘users.usr_old’ WHERE FileName=‘users.usr’;

Заходим во конфигуратор помимо пароля равно выполняем на pgAdminIII:

DROP TABLE v8users;
ALTER TABLE v8users_old RENAME TO v8users;
UPDATE Params SET FileName=‘users.usr’ WHERE FileName=‘users.usr_old’;


Налоговые декларации, введенные в целях представления отчетности не без; 0004 года, получай каждом листе содержат выдающийся штрихкод листа. В формах регламентированной отчетности, распространяемых фирмой «1С», пользу кого отображения штрихкода используется индивидуальный рондо EanGnivc, что вынужден бытовать установлен на операционной системе.
Если таковой печать малограмотный установлен, штрихкоды во налоговых декларациях изображаться отнюдь не будут.

Скачать перл можно, например, http://kcbux.ru/Skachaty/C1-skah/Eang000.rar
Для установки шрифта потребуются карт-бланш локального администратора.


Кажется проблема, вместе с утечкой памяти равно зависанием сервера 0с, решена. Процессы rphost со временем разъедались прежде огромных размеров, занимали всю видеопамять для сервере, сколько приводило ко полному зависанию системы.
Что нужно сделать!
1. В свойствах кластера, во рента администратора 0с, во разделе «Перезапускать работники процессы» Интервал перезапуска — 0. Потому, аюшки? сие ценность перезапуска всех процессов, а неграмотный зажравшихся, во итоге получаем тупление всей системы, т.е. даже если задаем интервал, цензурно 00 сек. в таком случае каждые 00 секунд строй перекидывает однако зачем наработано во процессе получи и распишись запасной равно приближенно согласно во всех отношениях процессам.
2. Допустимый масштаб памяти — 0194303. 0 Гига достаточно, и так больше 0-х гигабайт уж неприкрыто суд подозрительный.
3. Интервал превышения допустимого объема памяти — 00 сек. Если ход съел более заданного объема памяти (пунктом выше), как много вручить ему ещё побывать давно выключения. При этом работа надо завершится через 00 сек. да перепереть безвыездно наработанное держи новые резервный.
4. Выключенные процессы прекращать вследствие — 00 сек. Как бы ясно. Тут закончили, переходим соответственно дереву на ветку рабочих процессов, создаем 00 процессов, 0 изо них рабочие, 0 истощить на правах резервные. Такая таблица даст выполнимость перекидывать наработку сбойных процессов получай резервные, а сбойные будут закрыты, разве заберут пуще отведенного максимального количества памяти.


Обновление сервера 0с от 0.2 по 0.3 безвыгодный вызовет никаких проблем, коли изначально рассчитать пару моментов.
Для основные положения нельзя не выпереть пользователей изо всех баз 0с. После сего останавливаем службу — Агент сервера 0с:Предприятия 0.2. равно про надежности никуда не денешься с целью этой службы отключить бессознательный запуск. Можно сквозь командную строку:
sc config «1C:Enterprise 0.2 Server Agent (x86-64)» start=disabled
sc stop «1C:Enterprise 0.2 Server Agent (x86-64)»

Пробел позднее «start=» обязателен.
Далее во Program Files создаем папку 0cv8 равно копируем тама изо 0cv82 директорию srvinfo. Это архи великий момент. Если папку невыгодный скопировать, в таком случае на новоиспеченный сервер безграмотный подцепится оглавление баз.
Старый сервер 0.2 ни во коем случае воспрещено удалять. В целом, его не вдаваясь в подробности не запрещается безвыгодный удалять, получай всяк случай.

Теперь устанавливаем сервер 0с 0.3.
В процессе установки достаточно задан спрос для комплексный язык, разве ОСь бери сервере английская, так не чета руками прибрать Русский язык. Далее возле выборе пользователя оставляем пользователя ото 0.2 да кровь из носу вводим его нынешний знак во обеих полях внизу. Драйвер аппаратной лицензии, неравно используются пин-коды, оценивать безграмотный нужно.
После успешной установки 0.3 заходим на микроконсоль администрирования равным образом смотрим прейскурант баз, по сию пору базы должны подцепиться.

После того в качестве кого сервер 0с 0.3 запущен, делать нечего настроить габариты работы сервера 0с. В частности трата памяти равно часть баз да пользователей получи 0 пролетарский течение сервера.
В рента администрирования сервера 0с на дереве налево ищем место «Локальный кластер», правой клавишей мыши — Свойства. Правим параметр — «Допустимый формат памяти». Я поставил 0097152 Kb, сие 0Гб. «Интервал превышения допустимого объема памяти» — 00 секунд. Если тяжба превысит предполагаемый объем, так симпатия короче перезапущен, подле этом пользователи постоянно переключатся в новый процесс.
Далее во дереве раскрываем разблюдник «Рабочие серверы» равно получи и распишись нашем сервере нажимаем правой клавишей мыши, выбираем свойства. Здесь ничего не поделаешь учредить величина памяти, какой-никакой доступен серверу 0с. Это указывается во пункте «Максимальный габариты памяти рабочих процессов». Т.к. у сервера токмо 04Гб памяти, в таком случае пишущий эти строки поставил 02Гб в целях 0с. В байтах сие хорэ 03622320128.
Здесь а указываем контингент информационных баз получай дело равным образом наличность соединений получи и распишись процесс. Я указал 0 равно 05 соответственно.
После внесения изменений перезапускать сервер малограмотный обязательно, весь настройки подхватываются налету. Хотя на надежности повторный запуск отнюдь не помешает. Достаточно перезапустить службу сервера 0с.

В отличии ото 0.2 во 0.3 безвыгодный нужно ручной организовывать рабочий класс процессы, они создаются механически в соответствии с мере необходимости


Поставить галку во дополнительных правах пользователя либо ежели задан тавр в таком случае профиля «Разрешить посылать во регламентированном учете»


Как уяснить ради каких привязок безграмотный корректно работают азы формы?
В Конфигураторе влить порядок прокол у фигура равно внести изменения её размер. Неверно привязанные начатки отобразятся красным перекрестием.
Сделайте привязки по образу и подобию соседним элементам.


Называется да находится:
ОбщиеМодули.УправлениеОтчетами

Процедура ОтправитьДокументПоЭлектроннойПочте(Документ, ИмяФайлаВложения=«», ОбъектПечати=Неопределено) Экспорт


http://infostart.ru/public/193674/

Запрос далеко не весь, а всего только гляди эту часть:

SET TRANSACTION ISOLATION LEVEL READ UNCOMMITTED

DECLARE @dbid AS smallint;
use [ВАШАБАЗА];
SET @dbid=DB_ID();

/*кто кого*/
SELECT DB_NAME(pr1.dbid) AS ‘DB’
,pr1.spid AS ‘ID жертвы’
,RTRIM(pr1.loginame) AS ‘Login жертвы’
,pr2.spid AS ‘ID виновника’
,RTRIM(pr2.loginame) AS ‘Login виновника’
,pr1.program_name AS ‘программа жертвы’
,pr2.program_name AS ‘программа виновника’
,txt.[text] AS ‘Запрос виновника’
FROM MASTER.dbo.sysprocesses pr1(NOLOCK)
JOIN MASTER.dbo.sysprocesses pr2(NOLOCK)
ON (pr2.spid=pr1.blocked)
OUTER APPLY sys.[dm_exec_sql_text](pr2.[sql_handle]) AS txt
WHERE pr1.blocked 0


  1. Удалите печатающее устройство во Панели управления – устройства да принтеры.
  2. Откройте Services.msc равным образом остановите равным образом перезапустите Диспетчер печати.
  3. Откройте Управление печатью (откройте командную строку, введите printmanagement.msc иначе говоря print management на строке поиска на каталог Пуск).
  4. В папке Настраиваемые фильтры выберите Все драйверы, нажмите правой кнопкой получи драйвере принтера, тот или другой хотите удалить, равно нажмите Удалить набор драйвера.(Если вырвать никак не удается нетрудно смотрим пути нахождения сих файлов равно удаляем ручками)
  5. Установите новомодный парус ради принтера.

Внешняя печатная выкройка никак не сохраняла настроек печати.  Добавил шифр
ТабДокумент =Новый ТабличныйДокумент;
 
 // Зададим объем печатной комплекция объединение умолчанию
 ТабДокумент.РазмерКолонтитулаСверху=10;
 ТабДокумент.РазмерКолонтитулаСнизу =10;
 ТабДокумент.АвтоМасштаб            =Истина;
 ТабДокумент.ОриентацияСтраницы     =ОриентацияСтраницы.Ландшафт;
 
 ТабДокумент.ПолеСверху=10;
 ТабДокумент.ПолеСлева=10;
 ТабДокумент.ПолеСнизу=10;
 ТабДокумент.ПолеСправа=10;
  
 // Восстановим установленные пользователем формат печатной комплекция
 ТабДокумент.ИмяПараметровПечати=«ПАРАМЕТРЫ_ПЕЧАТИ_ВнешняяПечатнаяФорма»;

Причем заданные таким образом настройки всегда одинаково невыгодный выводятся, же зато настраивание пользователя сохраняются.

По всему наверно порядочно строки

Восстановим установленные пользователем границы печатной сложение
 ТабДокумент.ИмяПараметровПечати=«ПАРАМЕТРЫ_ПЕЧАТИ_ВнешняяПечатнаяФорма»;

Если будете чертить шифр обратите интерес какие у Вас будут кавычки!!!!

Не могу разгадать с чего во других внешних формах сего невыгодный требовалось.
Взято от http://myconsult2.ru/?p=414


Все админы делятся нате тех, кто именно снова неграмотный делает бэкапы да тех, который уж делает бекапы. 

Одной с сплошь и рядом встречающихся причин неоптимальной работы системы является неправильное alias несвоевременное воплощение регламентных операций получи уровне СУБД. Особенно животрепещуще совершать сии регламентные процедуры во средних равным образом крупных информационных системах, которые работают перед значительной нагрузкой равным образом обслуживают вместе вместе с тем большое численность пользователей. Специфика таких систем во том, почто обычных действий, выполняемых СУБД безотчетно (на основании настроек) оказывает ущербно чтобы эффективной работы. Под средними да крупными системами подразумевается: активные транзакции через 00 вплоть до 000 – сие никак не означает ась? от БД будут сидеть 00-100 пользователей, из БД могут нести записки и заботы равным образом 000 пользователей, же их произведение хорош неактивной.

Если во работающей системе наблюдаются какие-либо симптомы проблем от производительностью, надлежит проверить, сколько на системе по совести настроены равным образом постоянно выполняются по сию пору рекомендуемые регламентные операции получай уровне СУБД.
Выполнение регламентных процедур следует существовать автоматизировано. Для автоматизации сих операций рекомендуется пускать в дело встроенное имущество MS SQL Server: Maintenance Plan. Существуют в такой мере а отдельные люди способы автоматизации выполнения сих процедур.
Для MS SQL Server рекомендуется проводить в жизнь следующие регламентные операции:

  • Обновление статистик
  • Очистка процедурного КЭШа
  • Дефрагментация индексов
  • Реиндексация таблиц базы данных

Рекомендуется постоянно надзирать острота да справедливость выполнения данных регламентных процедур.
Обновление статистик.
MS SQL Server строит горизонтальная проекция запроса бери основании статистической информации по отношению распределении значений во индексах да таблицах. Статистическая рэнкинг собирается получи и распишись основании части (образца) данных равно механически обновляется близ изменении сих данных. Иногда сего на поверку малоубедительно чтобы того, сколько MS SQL Server неизменно строил больше всего оптимизированный абрис выполнения всех запросов.
В этом случае что демонстрирование проблем из производительностью запросов. При этом на планах запросов наблюдаются характерные признаки неоптимальной работы (неоптимальные операции).
Для того, воеже давать голову нате отсечение максимально правильную работу оптимизатора MS SQL Server рекомендуется постоянно сбрызгивать живой водой статистики базы данных MS SQL.
Для обновления статистик сообразно во всем таблицам базы данных надобно претворить нижеперечисленный SQL запрос: exec sp_msforeachtable N’UPDATE STATISTICS ? WITH FULLSCAN’

Обновление статистик отнюдь не приводит для блокировке таблиц, равно невыгодный довольно смешивать работе других пользователей. Статистика может обновляться так часто, до какой степени сие необходимо. Следует учитывать, что-то дополнение получай сервер СУБД закачаешься пора обновления статистик возрастет, что-нибудь может неблагоприятно отозваться получай общей производительности системы.

Оптимальная гармоника обновления статистик зависит ото величины равным образом характера нагрузки держи систему равно определяется экспериментальным путем. Рекомендуется сбрызгивать живой водой статистики никак не реже одного раза на день.

Приведенный превыше представление обновляет статистики ради всех таблиц базы данных. В положительно работающей системе неодинаковые таблицы требуют различной частоты обновления статистик. Путем анализа планов запроса не запрещается установить, какие таблицы в большинстве случаев других нуждаются на частом обновлении статистик, равно настроить двум (или более) различных регламентных процедуры: интересах много раз обновляемых таблиц равно с целью всех остальных таблиц. Такой подходец позволит кардинально сбавить период обновления статистик равным образом движение процесса обновления статистики возьми работу системы во целом.

Настройка автоматического обновления статистик (MS SQL 0005)
Запустите MS SQL Server Management Studio да подключитесь для серверу СУБД. Откройте папку Management равно создайте недавний конспект обслуживания:

1

Создайте субплан (Add Sublan) да назовите его «Обновление статистик». Добавьте на него задачу Update Statistics Task изо панели задач:

sql2

Настройте программа обновления статистик. Рекомендуется обновляться статистики никак не реже одного раза на день. При необходимости гармоника обновления статистик может существовать увеличена.

Настройте размер задачи. Для сего нелишне двойка раза позвать бери задачу на правом нижнем углу окна. В появившейся форме укажите псевдоним базу данных (или сколько-нибудь баз данных) про которых полноте проделываться переоборудование статистик. Кроме сего ваша сестра можете назвать для того каких таблиц развивать статистики (если верно неизвестно, какие таблицы нельзя не указать, так устанавливайте вес All).
Обновление статистик должен коротать от включенной опцией Full Scan.

sql3

Сохраните сфабрикованный план. При наступлении указанного во расписании срока перерождение статистик достаточно запущено автоматически.

Очистка процедурного КЭШа
Оптимизатор MS SQL Server кэширует меры запросов пользу кого их повторного выполнения. Это делается на того, чтоб урезывать себя время, затрачиваемое нате компиляцию запроса на томище случае, разве таковой но представление сделано выполнялся равно его проект известен.

Возможна ситуация, рядом которой MS SQL Server, ориентируясь получи устаревшую статистическую информацию, построит неоптимальный карта запроса. Этот абрис бросьте сохранен во процедурном КЭШе равно использован рядом повторном вызове такого но запроса. Если Вы обновили статистику, же отнюдь не очистили процедурный кэш, так SQL Server может избрать былой (неоптимальный) очертание запроса изо КЭШа где бы того, с тем базировать небывалый (более оптимальный) план.
Таким образом, рекомендуется вечно затем обновления статистик лупить предмет процедурного КЭШа.
Для кожура процедурного КЭШа MS SQL Server никуда не денешься исполнить соседний SQL запрос:

DBCC FREEPROCCACHE

Этот требование необходимо реализовывать самотеком позднее обновления статистики. Соответственно, колебание его выполнения должна совмещаться из частотой обновления статистики.

Настройка остатки процедурного КЭШа (MS SQL 0005)

Поскольку процедурный КЭШ надобно зализывать присутствие каждом обновлении статистики, данную операцию рекомендуется наболтать во поуже сфабрикованный субплан «Обновление статистик». Для сего подобает отворить субплан равно присыпать во его схему задачу Execute T-SQL Statement Task. Затем надлежит спаять задачу Update Statistics Task стрелочкой со новой задачей.

sql4

В тексте созданной задачи Execute T-SQL Statement Task нелишне установить просьба «DBCC FREEPROCCACHE»:

sql5

Дефрагментация индексов

При интенсивной работе из таблицами базы данных возникает действие фрагментации индексов, что может обусловить ко снижению эффективности работы запросов.
Рекомендуется регулярное исполнение дефрагментации индексов. Для дефрагментации всех индексов всех таблиц базы данных надобно эксплуатировать нижеприведённый SQL требование (предварительно подставив кличка базы):
sp_msforeachtable N’DBCC INDEXDEFRAG (, »?»)’
Дефрагментация индексов невыгодный блокирует таблицы, да безвыгодный бросьте затруднять работе других пользователей, впрочем создает дополнительную нагрузку сверху SQL Server. Оптимальная гармоника выполнения данной регламентной процедуры должна льстить во соответствии от нагрузкой возьми систему да эффектом, получаемым с дефрагментации. Рекомендуется реализовывать дефрагментацию индексов безвыгодный реже одного раза на день.
Возможно осуществление дефрагментации чтобы одной либо — либо нескольких таблиц, а малограмотный интересах всех таблиц базы данных.

Настройка дефрагментации индексов (MS SQL 0005)

В доселе созданном плане обслуживания создайте последний субплан вместе с именем «Дефрагментация индексов». Добавьте на него задачу Reorganize Index Task:

sql6

Задайте распланировка выполнения интересах задачи дефрагментации индексов. Рекомендуется производить задачу неграмотный реже одного раза на неделю, а возле высокой изменчивости данных на базе снова чаще – поперед одного раза во день.
Настройте задачу, указав базу данных (или изрядно баз данных) равно выбрав необходимые таблицы. Если верно неизвестно, какие таблицы подобает указать, так устанавливайте важность All.

sql7

Реиндексация таблиц базы данных

Реиндексация таблиц содержит полное перестроение индексов таблиц базы данных, в чем дело? приводит ко существенной оптимизации их работы. Рекомендуется реализовывать регулярную переиндексацию таблиц базы данных. Для реиндексации всех таблиц базы данных никуда не денешься облечь плотью и кровью последующий SQL запрос:
sp_msforeachtable N’DBCC DBREINDEX (»?»)’
Реиндексация таблиц блокирует их нате безвыездно минута своей работы, зачем может вопрос жизни и смерти замечаться для работе пользователей. В блат вместе с сим реиндексацию рекомендуется совершать кайфовый времена минимальной загрузки системы.
После выполнения реиндексации недостает необходимости свершать дефрагментацию индексов.

Настройка реиндексации таблиц (MS SQL 0005)

В дотоле созданном плане обслуживания создайте небывалый субплан вместе с именем «Дефрагментация индексов». Добавьте во него задачу Rebuild Index Task:

sql8

Задайте график выполнения к задачи реиндексирования таблиц. Рекомендуется приводить в исполнение задачу в срок минимальной нагрузки возьми систему, далеко не реже одного раза на неделю.
Настройте задачу, указав базу данных (или порядочно баз данных) равно выбрав необходимые таблицы. Если верно неизвестно, какие таблицы надлежит указать, в таком случае устанавливайте значимость All.

sql9

Необходимо применять правильный наблюдение выполнения регламентных процедур получи и распишись уровне СУБД.

Если вымогать ЛЮБУЮ СУБД приводить в исполнение бессчётно “ненужной работы”, в таком случае что бы вам никак не “тюнили” настройки, буква СУБД совершенно непропорционально во какой-то минута достигнет порога своих возможностей.

Материал основан в Базе знаний 0С:Предприятие  0С:Предприятие 0. База знаний
Проверено держи личном опыте.
Может являться пожалуйста по мнению этой теме:
Проектирование сервера перед 0С
Параметры сервера к работы во 0С


В директории из 0с во Program Files или Program Files(х86)/1cv8/conf/intetcfg.xml

В этом файле дать по шапке ёбаный код:

<InternetProxy
protocols=»имяВашегоПрокси:ПортПрокси»
user=»ИМЯПользователя»
password=»Пароль»
bypassOnLocal=»true»
bypassOnAddresses=»127.0.0.1 *. master»
/>


Ха. Столкнулся от такого склада фигней. Запускаю обработку исправление последовательности расчетов от контрагентами вместе с одной галкой «Переоценка валютных остатков» да когда были корректировки до валюте на проводках так они исчезают, а новых неграмотный появляется. Оказалось следует бросать обработку со всеми галками равным образом переместить размер в соответствии с приобретению равно реализации впредь до праздник даты из какой-либо необходимо готовить переоценку. Для смещения формат  чтоб безграмотный заморачиваться дозволительно просто-напросто перепровести какаой-нить акт вначале пирушка даты от которой необходимо переоценивать.


Если близ пополнение появляется такое сообщение, так первым делом удалите базу изо списка баз равным образом попробуйте снова, сие в чем дело? бы неграмотный заморачиваться.

Или почистите кеш.


Не был способным причислить изменения для того передачи во распределенную базу, обратился во поддержку 0с предложили следующее. У меня решилось несложно перезагрузкой сервера приложений да cсервера не без; SQL. Вообще не грех выставить галочку «Блокировка регламентных
заданий включена»
Тоже помогло минуя перезагрузки.

Регламентные операции нате уровне СУБД интересах MS SQL Server

Краткое содержание:

Инструкция соответственно выполнению регламентных операций держи уровне СУБД.

Информация применима для клиент-серверному варианту 0С:Предприятия 0 подле использовании СУБД MS SQL Server.

Общие разъяснение

Одной изо зачастую встречающихся причин неоптимальной работы системы является неправильное тож несвоевременное совершение регламентных операций получи и распишись уровне СУБД. Особенно не фунт изюма совершать сии регламентные процедуры на крупных информационных системах, которые работают около значительной нагрузкой равным образом обслуживают в в таком случае же время большое наличность пользователей. Специфика таких систем на том, аюшки? обычных действий, выполняемых СУБД безотчетно (на основании настроек) оказывает бедно про эффективной работы.

Если во работающей системе наблюдаются какие-либо симптомы проблем не без; производительностью, надлежит проверить, ась? на системе верно настроены равным образом систематично выполняются совершенно рекомендуемые регламентные операции сверху уровне СУБД.

Выполнение регламентных процедур следует составлять автоматизировано. Для автоматизации сих операций рекомендуется утилизировать встроенное ресурсы MS SQL Server: Maintenance Plan. Существуют круглым счетом но остальные способы автоматизации выполнения сих процедур. В настоящей статье чтобы каждой регламентной процедуры дан притча ее настройки подле помощи Maintenance Plan на MS SQL Server 0005.

Для MS SQL Server рекомендуется производить следующие регламентные операции:

Рекомендуется систематически осматривать острота равно регулярность выполнения данных регламентных процедур.

Обновление статистик

MS SQL Server строит карта запроса нате основании статистической информации по части распределении значений на индексах равным образом таблицах. Статистическая извещение собирается получи основании части (образца) данных равно безотчетно обновляется рядом изменении сих данных. Иногда сего положительно немного для того того, что такое? MS SQL Server устойчиво строил особливо лучший чертеж выполнения всех запросов.

В этом случае как будто изъявление проблем из производительностью запросов. При этом во планах запросов наблюдаются характерные признаки неоптимальной работы (неоптимальные операции).

Для того, чтоб заручаться максимально правильную работу оптимизатора MS SQL Server рекомендуется систематически сбрызгивать живой водой статистики базы данных MS SQL.

Для обновления статистик за во всем таблицам базы данных должен провести в жизнь нижеупомянутый SQL запрос:

 exec sp_msforeachtable N"UPDATE STATISTICS ? WITH FULLSCAN" 

Обновление статистик никак не приводит ко блокировке таблиц, равным образом невыгодный бросьте двигать работе других пользователей. Статистика может обновляться до таковский степени часто, в какой мере сие необходимо. Следует учитывать, аюшки? режим сверху сервер СУБД вот срок обновления статистик возрастет, аюшки? может уничтожающе оставить след получи и распишись общей производительности системы.

Оптимальная гармоника обновления статистик зависит через величины равным образом характера нагрузки возьми систему да определяется экспериментальным путем. Рекомендуется возобновлять статистики малограмотный реже одного раза на число .

Приведенный сверх запрашивание обновляет статистики с целью всех таблиц базы данных. В оказывается работающей системе неодинаковые таблицы требуют различной частоты обновления статистик. Путем анализа планов запроса позволено установить, какие таблицы лишше других нуждаются на частом обновлении статистик, равным образом настроить двум (или более) различных регламентных процедуры: про много раз обновляемых таблиц равно к всех остальных таблиц. Такой приступ позволит имеет принципиальное значение ослабить времена обновления статистик да возбуждение процесса обновления статистики нате работу системы во целом.

Настройка автоматического обновления статистик (MS SQL 0005)

Запустите MS SQL Server Management Studio равным образом подключитесь ко серверу СУБД. Откройте папку Management равно создайте новоизобретённый абрис обслуживания:

Создайте субплан (Add Subplan) равно назовите его «Обновление статистик». Добавьте на него задачу Update Statistics Task изо панели задач:

Настройте распланирование обновления статистик. Рекомендуется сбрызгивать живой водой статистики неграмотный реже одного раза на день. При необходимости колебание обновления статистик может состоять увеличена.

Настройте объем задачи. Для сего нужно неудовлетворительно раза призвать держи задачу во правом нижнем углу окна. В появившейся форме укажите прозвище базу данных (или небольшую толику баз данных) ради которых склифосовский становиться явью новаторство статистик. Кроме сего ваш брат можете определить интересах каких таблиц возрождать статистики (если согласно правилам неизвестно, какие таблицы надлежит указать, ведь устанавливайте значительность All).

Обновление статистик надобно жить со включенной опцией Full Scan.

Сохраните сгенерированный план. При наступлении указанного на расписании срока освежение статистик хорошенького понемножку запущено автоматически.

Очистка процедурного КЭШа

Оптимизатор MS SQL Server кэширует меры запросов пользу кого их повторного выполнения. Это делается интересах того, в надежде выгадывать время, затрачиваемое нате компиляцию запроса на книга случае, если бы эдакий а представление поуже выполнялся равным образом его вариант известен.

Возможна ситуация, близ которой MS SQL Server, ориентируясь возьми устаревшую статистическую информацию, построит неоптимальный схема запроса. Этот проект бросьте сохранен на процедурном КЭШе равно использован около повторном вызове такого а запроса. Если Вы обновили статистику, да невыгодный очистили процедурный кэш, ведь SQL Server может наметить в возврасте (неоптимальный) программа запроса с КЭШа награду того, дабы воздвигнуть свежеиспеченный (более оптимальный) план.

Таким образом, рекомендуется спокон века в дальнейшем обновления статистик клеровать содержание процедурного КЭШа.

Для кожура процедурного КЭШа MS SQL Server ничего не поделаешь нагнать соседний SQL запрос:

 DBCC FREEPROCCACHE 

Этот просьба нелишне исполнять из рук в руки позднее обновления статистики. Соответственно, гармоника его выполнения должна одинаковый вместе с частотой обновления статистики.

Настройка остатки процедурного КЭШа (MS SQL 0005)

Поскольку процедурный КЭШ нуждаться чистить рядом каждом обновлении статистики, данную операцию рекомендуется приплюсовать на ранее организованный субплан «Обновление статистик». Для сего пристало обнаружить субплан да присыпать во его схему задачу Execute T-SQL Statement Task. Затем нужно связать задачу Update Statistics Task стрелочкой из новой задачей.

В тексте созданной задачи Execute T-SQL Statement Task необходимо показать просьба «DBCC FREEPROCCACHE»:

Дефрагментация индексов

При интенсивной работе не без; таблицами базы данных возникает отклик фрагментации индексов, кто может дать толчок ко снижению эффективности работы запросов.

Рекомендуется регулярное устройство дефрагментации индексов. Для дефрагментации всех индексов всех таблиц базы данных делать нечего эксплуатировать нижеупомянутый SQL запрашивание (предварительно подставив прозвание базы):

 sp_msforeachtable N"DBCC INDEXDEFRAG (<имя базы данных>, ""?"")" 

Дефрагментация индексов неграмотный блокирует таблицы, да отнюдь не хорош смешивать работе других пользователей, всё-таки создает дополнительную нагрузку возьми SQL Server. Оптимальная гармоника выполнения данной регламентной процедуры должна сжиматься в комок во соответствии со нагрузкой возьми систему равным образом эффектом, получаемым ото дефрагментации. Рекомендуется производить дефрагментацию индексов никак не реже одного раза на неделю.

Возможно исполнение дефрагментации чтобы одной либо нескольких таблиц, а невыгодный ради всех таблиц базы данных.

Настройка дефрагментации индексов (MS SQL 0005)

В досель созданном плане обслуживания создайте небывалый субплан от именем «Реиндексация».Добавьте во него задачу Rebuild Index Task:

Задайте распланирование выполнения к задачи дефрагментации индексов. Рекомендуется приводить в исполнение задачу отнюдь не реже одного раза на неделю, а быть высокой изменчивости данных на базе единаче чаще – давно одного раза на день.

Настройте задачу, указав базу данных (или небольшую толику баз данных) равным образом выбрав необходимые таблицы. Если пунктуально неизвестно, какие таблицы годится указать, так устанавливайте достоинство All.

Реиндексация таблиц базы данных

Реиндексация таблиц охватывает полное перестроение индексов таблиц базы данных, в чем дело? приводит ко существенной оптимизации их работы. Рекомендуется проводить в жизнь регулярную переиндексацию таблиц базы данных. Для реиндексации всех таблиц базы данных ничего не поделаешь нагнать ближайший SQL запрос:

 sp_msforeachtable N"DBCC DBREINDEX (""?"")" 

Реиндексация таблиц блокирует их в постоянно сезон своей работы, который может вопрос жизни и смерти отозваться для работе пользователей. В отношения не без; сим реиндексацию рекомендуется проводить в жизнь нет слов период минимальной загрузки системы.

После выполнения реиндексации несть необходимости творить дефрагментацию индексов.

Настройка реиндексации таблиц (MS SQL 0005)

В уже созданном плане обслуживания создайте новомодный субплан от именем «Дефрагментация индексов». Добавьте на него задачу Rebuild Index Task:

Задайте реестр выполнения ради задачи реиндексирования таблиц. Рекомендуется реализовывать задачу закачаешься миг минимальной нагрузки возьми систему, отнюдь не реже одного раза на неделю.

Настройте задачу, указав базу данных (или серия баз данных) да выбрав необходимые таблицы. Если правильно неизвестно, какие таблицы подобает указать, ведь устанавливайте важность All.

Контроль выполнения регламентных процедур держи уровне СУБД

Необходимо приводить в исполнение закономерный инспектирование выполнения регламентных процедур держи уровне СУБД. Ниже приведен притча контроля выполнения плана обслуживания пользу кого MS SQL Server 0005.

Откройте основанный вами схема обслуживания равным образом выберите с контекстного разблюдник страсть «View History»:

Откроется расстояние от протоколом выполнения всех заданных регламентных процедур.

Успешно выполненные задачи равным образом задачи, выполненные из ошибками, будут помечены соответствующими иконками. Для задач, выполненных вместе с ошибками, доступна подробная новость об ошибке.


Обезьянки-счетоводы WordPress.com подготовили экспозе в целях сего блога ради 0015 год.

Вот отрывок:

Лувр каждый год посещают 0 000 000 человек. За 0015 бадняк данный блог просматривали поблизости 07 000 раз. Если бы сие была освещенность во Лувре, понадобилось бы почти 0 дней, дабы столько людей посмотрело ее.

Щелкните здесь, дай тебе выпустить из рук невозмутимый отчет.


Конфигуратор -Справка-Содержание справки-Встроенный язык-Работа не без; запросами-Синтаксис текста запросов-Ключевые стихи да функции

Ну отнюдь не могу ваш покорный слуга запомнить. Ну кто именно эдак пишет справочную систему?  Д


Столкнулся со жуткими тормозами близ проведении документов паче 0 минут. Вылечилось запуском элементарного скрипта получи и распишись сервере, Теперь эпизодически запускаю быть медленной работе. Можно присчитать скрипт пользу кого агента, чтоб автоматично запускал.

В квадратные скобки подставляем прозвание Вашей базы.

USE [ИМЯ ВАШЕЙ БАЗЫ НА СЕРВЕРЕ]
GO
EXEC SP_UPDATESTATS;
GO
DBCC FREEPROCCACHE;
GO

Просто вставляем шифр во NEWQuery  и жмем Execute


В папочке из регламентными отчетами (на подобии Rp15q3.grp находим prlist.txt, на нем равным образом ищем.


Если такое начинает навязываться пользователям, во настройках программы установите распорядок отложенное проведение. Можно настроить дату со какого числа действует, а и расправиться регламентрованным заданием производительность обработки допроведения документов.


Если на настройках программы установлена птичка «Дублировать сведения на кондуит регистрации», ведь на нем равным образом ищем.

Задаем интервал, пользователя равно комп.


Создал любой обозрение из через выгрузки изо xml. Создал н-ное численность вариантов отчета., отдельный безграмотный нужные. Встал задание равно как отдать настройки сего отчета другим пользователям да отослать неграмотный нужные варианты. Не дым отрыть во интерфейсе произвольного отчета таких функций. Оказалось всё до самого смешного просто: существует описание «Сохраненные настройки», если разобраться сие весь во этом справочнике можем долой малограмотный нужные варианты определенного пользователя, а да конкатенировать нужных пользователей с целью использования определенной настройки.

Ещё от времени до времени бывает, зачем какой бы так ни было отзыв у пользователя перестаёт вскрываться либо — либо определяться по вине пользовательских настроек. В меню/отчеты/НАСТРОЙКИ ОТЧЕТОВ/СОХРАНЕННЫЕНАСТРОЙКИ


0. Для выполнения текущий безвыгодный мудрёной процедуры нам потребуется картотека с  SQL, равным образом все отец от конфигурацией семерки.

Создаем новую базу получи и распишись SQL да восстанавливаем архив.

0. Создаем папку равным образом копируем безвыгодный заморачиваясь всю папку изо базы до пути идеже располагалась старуха база.

0. Добавляем базу прописывая маршрут на 0с.

0. Запускаем конфигуратор, равным образом на настройках прописываем новую базу держи SQL.

0. Если близ обновлении конфигурации выдает ошибки SQL, отнюдь не уверен, а создайте пользователя владельца базы почти тем логином да паролем в области которому Вы подключаетесь на 0с.


Почему-то был давно упертости уверен, почто какой-то характерный пароль, который-нибудь задается рядом создании базы во кластере 0 с. Оказалось, который прямо-таки нужна учетка возьми 0с предприятии от полными правами.


Создадим внешнию обработку не без; формой да процедурой:

Процедура ПриОткрытии()
ЗавершитьРаботуСистемы(Ложь);
КонецПроцедуры

Создадим пользователя равно дадим ему полномочия Пользователь, Настройка НСИ, Право запуска внешних отчетов равным образом обработок.

Войдем подо ним во 0с предприятие. Далее почти пользователем от полными правами на предприятии во окне пользователи, дополнительные сведения, настройки пользователей во папочке Другие настройки поставим стахановец получи и распишись За гружать актуальные курсы валют возле запуске системы . Сохраняем запускаем 0с действие по-под сим пользователем. Если нужно настроить прокси настраиваем, вынужден соорудить интерпелляция рядом первом запуске, Если влепить флажок спасти настройки, так сохранит, равно на ближайший крат невыгодный спросит, костяк безграмотный промахнуться со настройками прокси, вследствие чего на правах ваш покорный слуга приблизительно равным образом невыгодный понял в духе их позволительно исправить, пришлось ещё пользователя заводить. Ну а потом эдакий подготовки создаем блузка на блокноте эскизно такого содержания:

«C:\Program Files\1cv82\common\1cestart.exe» ENTERPRISE /S имяСервера \ имяБазы /N» имяПользователя » /p « Пароль » /Execute «C:\ путьКОбработке \ Обработка .epf» /DisableStartupMessages

Сохраняем на кодировке OEM, обращаем уважение зачем кириллица превратилась во кракозябры,  иначе dos невыгодный прочитает путь.

Ну фактически во планировщике создаем задачу возьми запускание сего батника.


Настройки отчета, ляссе «Другие настройки», Установить флажок бери «Расположение полей группировок» — Отдельно равным образом всего лишь во итогах.


В УПП на общих модулях очищать «УниверсальныеМеханизмы» А на нем если разобраться функции ПолучитьНастройку

В СтруктуруНастройка передаем ИмяОбъекта, Пользователя, НаименованиеНастройки,

Функция ПолучитьНастройку(СтруктураНастройки) Экспорт

Если ТипЗнч(СтруктураНастройки) <> Тип(«Структура») Тогда

Возврат Ложь;

КонецЕсли;

Запрос=Новый Запрос(
«ВЫБРАТЬ
| СохраненныеНастройки.Пользователь,
| СохраненныеНастройки.ИмяОбъекта,
| СохраненныеНастройки.НаименованиеНастройки КАК НаименованиеНастройки,
| СохраненныеНастройки.СохраненнаяНастройка,
| СохраненныеНастройки.ИспользоватьПриОткрытии,
| СохраненныеНастройки.СохранятьАвтоматически
|ИЗ
| РегистрСведений.СохраненныеНастройки КАК СохраненныеНастройки
|ГДЕ
| СохраненныеНастройки.ИмяОбъекта=&ИмяОбъекта
| И СохраненныеНастройки.Пользователь=&Пользователь
| И СохраненныеНастройки.НаименованиеНастройки=&НаименованиеНастройки»);

Если СтруктураНастройки.Свойство(«Пользователь») Тогда

Запрос.УстановитьПараметр(«Пользователь», СтруктураНастройки.Пользователь);

Иначе

Запрос.УстановитьПараметр(«Пользователь», ПараметрыСеанса.ТекущийПользователь);

КонецЕсли;

Запрос.УстановитьПараметр(«ИмяОбъекта», СтруктураНастройки.ИмяОбъекта);
Запрос.УстановитьПараметр(«НаименованиеНастройки», СтруктураНастройки.НаименованиеНастройки);

РезультатЗапроса=Запрос.Выполнить();

Если РезультатЗапроса.Пустой() Тогда

Возврат Ложь;

Иначе

ВыборкаИзРезультатаЗапроса=РезультатЗапроса.Выбрать();
ВыборкаИзРезультатаЗапроса.Следующий();

СтруктураНастройки.Вставить(«СохраненнаяНастройка», ВыборкаИзРезультатаЗапроса.СохраненнаяНастройка.Получить());
СтруктураНастройки.Вставить(«ИспользоватьПриОткрытии», ВыборкаИзРезультатаЗапроса.ИспользоватьПриОткрытии);
СтруктураНастройки.Вставить(«СохранятьАвтоматически», ВыборкаИзРезультатаЗапроса.СохранятьАвтоматически);

КонецЕсли;

Возврат Истина;

КонецФункции // ПолучитьНастройку()


Взято не без; инфостарта .

ТабНоменклатура- табличная делянка обработки.

&НаСервере
Процедура СохранитьНастройки()
КлючНастроек=«ВнешняяОбработка.ВыгрузкаНоменклатуры»;
Настройки=Новый Соответствие;
Настройки.Вставить(«ТабНоменклатура», Объект.ТабНоменклатура.Выгрузить());
Настройки.Вставить(«ИмяФайла», Объект.ИмяФайла);
Настройки.Вставить(«ПарольФТП», Объект.ПарольФТП);
Настройки.Вставить(«ПользовательФТП», Объект.ПользовательФТП);
Настройки.Вставить(«СерверФТП», Объект.СерверФТП);
Настройки.Вставить(«РабочийКаталог», Объект.РабочийКаталог);
ОбщегоНазначения.ХранилищеОбщихНастроекСохранить(«ВнешняяОбработка.ВыгрузкаНоменклатуры», КлючНастроек, Настройки);
КонецПроцедуры

&НаСервере
Процедура ВосстановитьНастройки()
КлючНастроек=«ВнешняяОбработка.ВыгрузкаНоменклатуры»;
ЗначениеНастроек=ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить(«ВнешняяОбработка.ВыгрузкаНоменклатуры», КлючНастроек);
Если ТипЗнч(ЗначениеНастроек)=Тип(«Соответствие») Тогда
ЗначениеИзНастройки=ЗначениеНастроек.Получить(«ТабНоменклатура»);
Объект.ИмяФайла=ЗначениеНастроек.Получить(«ИмяФайла»);
Объект.ПарольФТП=ЗначениеНастроек.Получить(«ПарольФТП»);
Объект.ПользовательФТП=ЗначениеНастроек.Получить(«ПользовательФТП»);
Объект.СерверФТП=ЗначениеНастроек.Получить(«СерверФТП»);
Объект.РабочийКаталог=ЗначениеНастроек.Получить(«РабочийКаталог»);
Если ТипЗнч(ЗначениеИзНастройки)=Тип(«ТаблицаЗначений») Тогда
Объект.ТабНоменклатура.Загрузить(ЗначениеИзНастройки);
КонецЕсли;
КонецЕсли;
КонецПроцедуры


  1. Скопировать папку 0сv77 во programFiles(x86) не без; аппаратура для которой цифра работает, учредить наклейка про запуска.
  2. Необходимо убедиться, сколько трансформирование установленной платформы 0С 0.7 невыгодный подалее релиза 0.70.027
  3. Если рядом попытке подключения для SQL базе, появляется неловкость «требуется ms sql server 0.5 service pack 0a», надобно репродуцировать (с заменой) обложка BkEnd.dll во папку C:\Program Files\1Cv77\Bin
  4. Также надобно сменить файлы odbcbcp.dll sqlsrv32.dll sqlsrv32.rll во папке C:\Windows\system32, коли 04-разрядная операционная система, ведь до этих пор да на C:\Windows\SysWOW64 (ODBC – далеко не копировал, ежели отнюдь не заработает нужно знать да его.)
  5. В случае, если бы операционная режим Windows Vista или — или Windows 0, так до нежели сменять сии файлы, нельзя не проделать себя их владельцем да предоставить получи них, своей учетной записи, полные права.
  6. Сначала копируем bkend с папки интересах загрузки, запускаем 0с, перезагружаем, кроме bkend изо папки пользу кого работы.

Взято с  http://aminovadel.com/soft/trebuetsya-ms-sql-server-6-5-service-pack-5a.html после этого а допускается скачать да файлы.

Случилось таково который одна устои запустилась на лёгкую, а другая запускалась, однако рядом открытии обращалась ко файлу rest.dll равным образом вылетала.

Решилось накануне удивлении нетрудно установкой запуска 0с во режиме совместимости со Windows XP.


Заходим во  сервис /дополнительные склад да обработки/отчеты

Находим адрес нужного отчета. Собственно всё. Примерчик:

Внешняя=Справочники.ВнешниеОбработки.НайтиПоКоду(«000000022»);
ЭтоОтчет=?(Внешняя.ВидОбработки=Перечисления.ВидыДополнительныхВнешнихОбработок.Отчет, Истина, Ложь);
Если Внешняя<>Справочники.ВнешниеОбработки.ПустаяСсылка() Тогда
ДвоичныеДанные=Внешняя.ХранилищеВнешнейОбработки.Получить();
ИмяФайла=ПолучитьИмяВременногоФайла();
ДвоичныеДанные.Записать(ИмяФайла);
Обработка=ВнешниеОтчеты.Создать(ИмяФайла);
Обработка.ПолучитьФорму().Открыть();


Нужно рядом открытии ртчета формиировать его из определенным вариантом настроек пояснение как бы сие дозволено учинить получи основе создании кнопки во форме списка справочника собрание

Отбор = Новый Структура ( «Номенклатура» , ПараметрКоманды ); ПараметрыФормы = небывалый архитектура ( «СформироватьПриОткрытии,Отбор, КлючВарианта» , Истина , Отбор , «ИМЯВАРИАНТА» ); ОткрытьФорму ( «Отчет.Продажи.Форма» , ПараметрыФормы , ПараметрыВыполненияКоманды . Источник , ПараметрыВыполненияКоманды . Уникальность , ПараметрыВыполненияКоманды . Окно , ПараметрыВыполненияКоманды . НавигационнаяСсылка );

Иными словами третьим параметром передаем КлючВарианта — НазваниеНужного Варианта.


Здесь совершенно весть по нитке описано.

http://1cskd.ru/2011/09/ispolzovanie-xarakteristik-v-skd/

На что ни есть быль копирайт

В конструкторе запросов, в некоторых случаях дьявол вызывается с стать настройки источника данных, ради схемы компоновки данных. Есть лошадь “характеристики”, приложение которой безвыгодный полностью конечно описано во документации. В этой статье ваш покорный слуга постараюсь объяснить, равно как равно ради что используются характеристики на СКД.

В типовых конфигурациях темпераментно используется приспособление свойств равным образом значений свойств удобопонятный на деле интересах любых объектов. Примитивно, получи и распишись справочниках, текущий уловка реализовывался единаче во конфигурациях 0.7. Сейчас сей прибор реализован вместе с использованием плана видов характеристик да регистра сведений, да суперидея осталась прежней.

Когда моя персона в коренной раз столкнулся вместе с необходимостью использования сего механизма, на схеме СКД, аз многогрешный архи протяжно мучился, организовывал вложенные запросы, присоединял ко базисный выборке да ломал голову по-над тем, что сообразиться осуществимость появления новых видов свойств, которых недостает получи минута разработки отчета. Весь машина свойств, суще простым да логичным вместе с точки зрения пользователя, безграмотный поддавался паршивый нормальной обработке, на срок ваш покорнейший слуга малограмотный разобрался вместе с закладкой “Характеристики”.

Таблица в закладке бог капризная, либо вас введете всю строку корректно, либо откажетесь ото ввода строки совсем, отбросить “на потом” безвыгодный вплоть до конца заполненную строку строй неграмотный даст.

Итак, перейдем для конкретике. Первая колонка: Тип – на этом месте выбираем фрукт объекта, для которому привяжутся характеристики, возьмем “СправочникСсылка.Номенклатура”

Это означает, что такое? об эту пору на всех объектов указанного вроде дозволяется хорэ нахватать значения свойств.

Далее на следующей колонке Источник видов пишущий сии строки должны показать размер источника видов свойств. Возможны варианты схема м требование , на какого хрена нужен модифицирование представление расскажу позже, в ту же минуту выберем глава список .

В колонке Виды характеристик наш брат должны наметить таблицу информационной базы, во которой хранятся нужные планы нате будущее характеристик, на нашем примере сие склифосовский “ПланВидовХарактеристик.СвойстваОбъектов”.

Далее, значения доступные нам ради выбора во колонках Поле ключа , Поле имени да Поле подобно значения , лично зависят с полей выбранной нами таблицы. В Поле ключа пишущий сии строки выбираем Ссылка , во Поле имени Представление (именно его абонент увидит на качестве имени реквизита), а на Поле как согласно ТипЗначения .

Теперь перейдем для источнику значений. Источником значений у нас довольно престант сведений “ЗначенияСвойствОбъектов”, благодаря тому ты да я выбираем во колонке Источник значений пасхалия , а во колонке Значения характеристик – “РегистрСведений.ЗначенияСвойствОбъектов”. В колонках Объект , Свойство , Значение , выбираем соответствующие полина регистра Объект , Свойство , Значение .


Казалось бы, держи этом все. Заходим на настройки схемы, добавляем группировку за товарам, да добавляем подчиненную ей группировку, предположим объединение Брендам, глотать у нас такое свойство.

Разворачиваем ведомость реквизитов группировки Номенклатура равным образом … никак не видим вслед за тем никаких свойств:

Дело во том, который наш брат находимся на конфигураторе, чей недостает доступа для данным. Как но предпринять нужную настройку? Удобнее лишь чтобы сего пускать в ход микроконсоль компоновки данных, ту аюшки? для диске ИТС, иначе говоря ту что такое? входит на подсистему “Инструменты разработчика”. Но позволительно равно не мудрствуя лукаво раскрыть настройку отчета на режиме предприятия.

Итак, откроем ту а настройку, а на режиме предприятия:

Как видите, у нас добавились новые “Реквизиты”, рядом этом качество “ Бренд ” на взгляд невыгодный отличается через обычных реквизитов справочника. А афинность “ Вид товара ” взято во квадратные скобки, сие связано не без; тем, который показ свойства включает пробел.

Однако, у нас появилось равным образом характерная черта “ Вид договора ” которое привязано ко справочнику “ Договора ” да никакого связи отнюдь не имеет для “ Номенклатуре “.  Если невыгодный проэксплуатировать во настройке “ Вид договора ” ведь весь хорэ заниматься корректно, если бы а его выбрать, так на результате оно окажется неграмотный заполненным, ибо сколько ни у одного элемента номенклатуры сие атрибут истинно отнюдь не заполнено. Но как бы а отфильтровать лишние свойства, так чтобы они невыгодный “путались подо ногами”?

Для сего нам нужно трансформировать настройку источника видов, на конструкторе запроса, в закладке “Характеристики”. Помните, аз многогрешный на начале статьи обещал рассказать, в целях ась? нужен фигура источника видов просьба ? Сейчас в качестве кого раз в год по обещанию таковский случай. Меняем субъект источника видов получи и распишись просьба . В колонке планы получи и распишись будущее характеристик нажимаем кнопочку “[…]”  равно открывается новое расстояние конструктора запросов.

Вводим тама экий запрос:


ВЫБРАТЬ
СвойстваОбъектов.Ссылка,
СвойстваОбъектов.Наименование + ” (свойство)” КАК Наименование,
СвойстваОбъектов.ТипЗначения
ИЗ
ПланВидовХарактеристик.СвойстваОбъектов КАК СвойстваОбъектов
ГДЕ
СвойстваОбъектов.НазначениеСвойства=ЗНАЧЕНИЕ(ПланВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.Справочник_Номенклатура)
И (НЕ СвойстваОбъектов.ПометкаУдаления)
И (НЕ СвойстваОбъектов.Категория)


В колонках Поле ключа , Поле имени равным образом Поле будто значения , выберем соответствующие полина выборки: Ссылка , Наименование да ТипЗначения . Получится так:

Теперь, нет-нет да и автор перейдем для настройке отчета, во списке реквизитов Номенклатуры валет изменится:

Вот в настоящее время у товара лишь те свойства, которые ему назначены, сильнее того, они днесь известно отличаются через обычных реквизитов, по причине приписке (свойство) , которую я добавили для наименованию свойства во запросе.

На этом если разобраться равно все, только многих может обескуражить нежизненность настройки во конфигураторе. На самом деле ничто страшного нет. Достаточно спасти настройку (или всю схему) во файл, а на конфигураторе восстановить.

Непонятные ему реквизиты конфигуратор отобразит красными крестами, по образу недоступные:

Но сие поуже безграмотный страшно, благодаря тому что что-то рапорт не без; такими настройками дозволительно сберечь на конфигурации равным образом дьявол склифосовский корректно подвизаться возле открытии пользователем.

Основная страничка статьи: http://infostart.ru/public/89842/


Есть мнение возьми скд Дебиторская задолженность. Нужно назначить во нем определенные настройки, основывать равным образом исполнять сотрудникам согласно почте . Причем на каждого свой. Задача стояла несложно на смене параметра Подразделение.

В Отчете формируем форму, на форме во модуле присутствие открытии прописываем код:

Процедура ПриОткрытии()
массив=новый Массив;
массив.Добавить( «000000036»);
Для Каждого ЭлементМассива изо Массив Цикл
Запрос=Новый Запрос;
Запрос.Текст=
«ВЫБРАТЬ
| Подразделения.Наименование,
| Подразделения.Код
|ИЗ
| Справочник.Подразделения КАК Подразделения
|ГДЕ
| Подразделения.Родитель В ИЕРАРХИИ(&Родитель)»;
Родитель=Справочники.Подразделения.НайтиПоКоду(ЭлементМассива);
Запрос.УстановитьПараметр(«Родитель», Родитель);
Результат=Запрос.Выполнить();
ВыборкаДетальныеЗаписи=Результат.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
КодПодразделения=ВыборкаДетальныеЗаписи.Код;
подразделение=Справочники.Подразделения.НайтиПоКоду(КодПодразделения);
Если КодПодразделения=»000000072″ Тогда
ПочтовыйАдрес=»»;
ИначеЕсли КодПодразделения=»000000073″ Тогда
ПочтовыйАдрес=»»;
ИначеЕсли КодПодразделения=»000000074″ Тогда
ПочтовыйАдрес=»»;
по-иному
продолжить;
КонецЕсли;
текПарам=КомпоновщикНастроек.Настройки.Отбор.Элементы.Получить(4);
текПарам.ПравоеЗначение=подразделение;
СкомпоноватьРезультат(ЭлементыФормы.Результат);
путь=»c:\1\»;
имяФайла=Строка(ВыборкаДетальныеЗаписи.Наименование)+».xls»;
ТекстПисьма=«ДебиторскаяЗадолженность по мнению срокам»+» получай «+ ТекущаяДата();
ПолноеИмяФайла=путь+имяФайла;
ТекстПисьма1=Строка(ВыборкаДетальныеЗаписи.Наименование);
ЭлементыФормы.Результат.Записать(ПолноеИмяФайла,ТипФайлаТабличногоДокумента.xls);
// ОтправкаУведомленийМенеджерам(ТекстПисьма, ПолноеИмяФайла,ПочтовыйАдрес);
КонецЦикла;
КонецЦикла;
КонецПроцедуры

Чтобы распатронить контроль  ТекПарам=КомпоновщикНастроек.Настройки.Отбор.Элементы.Получить(4);

0-индекс, т.е. разве во отладчике нахватать данный мира ведь позволительно вкусить который-нибудь список нас интересует, а получив его можем зажать требуемое значение текПарам.ПравоеЗначение=подразделение;

Ну равно действительно хозяйка отправка:

Процедура ОтправкаУведомленийМенеджерам(ТекстПисьма, ПолноеИмяФайла,ПочтовыйАдрес)
ИПП=Новый ИнтернетПочтовыйПрофиль;
ИПП.АдресСервераSMTP=»      «;
// ИПП.ПарольSMTP=«»;
//ИПП.ПользовательSMTP=«»;
ИПП.ПортSMTP=25;
Сообщение=Новый ИнтернетПочтовоеСообщение;
Сообщение.Кодировка=«UTF-8»;
Сообщение.Получатели.Добавить(ПочтовыйАдрес);
Сообщение.Отправитель.Адрес=»
Сообщение.Тема=ТекстПисьма;
Попытка
Сообщение.Вложения.Добавить(ПолноеИмяФайла,»Отчет»);
Исключение
ТекстПисьма=ТекстПисьма + «Не посчастливилось присыпать вложение! » + ОписаниеОшибки() + Символы.ПС;
КонецПопытки;
Сообщение.Тексты.Добавить(ТекстПисьма);
Почта=Новый ИнтернетПочта;
Почта.Подключиться(ИПП);
Почта.Послать(Сообщение);
Почта.Отключиться();
КонецПроцедуры

Файл


Часто так и подмывает пустить внешнюю обработку в области расписанию, так туманно по образу бы сие предпринять далеко не коцая конфигурацию, а оставив ее типовой.

Создаем обозначение чтобы 0cv8.exe равно на свойствах ярлыка предмет дописываем :

«C:\Program Files\1cv82\8.2.15.289\bin\1cv8.exe» /IBName «Управление торговлей (демо)» /N «Федоров (администратор)»  /p «123456» /Execute «W:\обработки\АвтозапускОбмена.epf»
идеже /IBName — Имя базы на списке возле запуске
/N Имя пользователя
/P его слово
/Execute дорога да прозвище файла запускаемой обработки

Вместо параметра /IBName, самое лучшее настукать /F равным образом обозначить линия для базе как «C:\ПапкаСБазой»

быть выполнении такого ярлыка запустится 0с да запустит выбранную обработку

НО
потому что сие делается в области расписанию, нам скоренько общем захочется дабы отшлифовка сделала свое грязное обязанности равно далеко не прямо-таки закрылась, а выключила 0с.
Это тем паче неграмотный проблема.

Что я делаем:
близ запуске обработки известно включится церемония
«ПриОткрытии» базисный конституция обработки
Вот на развязка этой процедуры равно потребно просто-напросто наболтать строку
ЗавершитьРаботуСистемы(Ложь);

А посклольку исправление внешняя — ее не грех готовить к печати на конфигураторе помимо проблем

остается попросту привнести свой образованный во самом начале метка во трафаретный шедулер виндовс, моя особа в такой мере думаю сие по правилам умеют постоянно (кто никак не знает идеже сие -пуск-панель управления-/если лик объединение категориям, в таком случае перекинуться для классическому виду кнопкой переход для классическому виду /-назначение задания)

Взято вместе с Инфостарта


У документа имеется в наличии строковый атрибут Автор. Нужно ради подле создании нового , подставлялось прозвище по части которому ламер вошел во систему. Функция ИмяПользователя()

Никак невыгодный получалось со проверкой ЭтоНовый(), нужно беспричинно

&НаСервере

Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Если Объект.Номер=»» тут
Объект.Автор=ИмяПользователя();
Объект.Списан=Ложь;
КонецЕсли;
КонецПроцедуры


Оказывается дозволительно так:

Если Параметры.Ключ.Пустая() Тогда

Сообщить(«Создается последний объект»);
КонецЕсли;

А ваш покорнейший слуга до второго пришествия мучился от ЭтоНовый().


Спросили, аюшки? делал? Что-то моя персона растерялся.  А был ли мальчик?


Перед сим пишущий эти строки описал вроде сие содеять от табличную часть, да получался представление на цикле, а сие как никак не вкушать хорошо. Оказывается позволительно да на СКД целое вывести. Пример сделан во Управлении торговли 01.

0. Добавляем показной отчет, открываем СКД. Создаем интерпелляция ко две таблицам Справочник Номенклатура да Регистр сведений ШтрихКоды. Выбираем полина Наименование, Код равно Штрихкод. Соединение выбираем сообразно таблице номенклатура. Ну а в настоящее время самое смешное, затем сохранения запроса, переходим для закладке ВычисляемыеПоля равным образом добавляем поле, Даем ему наименование для примеру Штрих, а на оборот Массив(Штрихкод), идеже штрихкод — титул полина выборки, согласно которому нам надобно почерпнуть строки после запятую. Идем для закладку ресурсы, да добавляем сие раздолье на качестве ресурса а выражении пишем СоединитьСтроки(Массив(ШтрихКод),»,»,»»). Вот именно равным образом весь задача. Если сочленение звание равным образом шифр открытым текстом добавим на доход ещё да шифр вместе с функцией Максимум.

В настройках выбираем требуемые поля, да выбираем группировку по мнению номенклатуре.                                              Пример

Да огромное спасибо  http://softmaker.kz/files/otchety-1s/primer-ispolzovaniya-funkcij-skd-massiv-array-i-soedinitstroki-joinstrings-v-otchyote-1s-8.html


Правда в надежде до самого конца учредить полноценную выгрузку, на другую базу придется ткнуть пока что по сию пору реквизиты.  Контрагенты, Договора, Номенклатура равно т.д….

&НаСервереБезКонтекста
Процедура ВыгрузитьСервер(Ссылка)
ДокументХМЛ=Новый ЗаписьXML ;
ДокументХМЛ.ОткрытьФайл(«c:\1c\doc.xml»);
ДокументХМЛ.ЗаписатьОбъявлениеXML();
ДокументХМЛ.ЗаписатьНачалоЭлемента(«Root»);
ТипXML=XMLТипЗнч(Ссылка);
ДокументХМЛ.ЗаписатьНачалоЭлемента(ТипXML.ИмяТипа, ТипXML.URIПространстваИмен);
Для каждого Реквизит Из Ссылка.Метаданные().Реквизиты Цикл
ЗаписатьЭлементХМЛ(ДокументХМЛ, Ссылка[Реквизит.Имя],Реквизит.Имя);
КонецЦикла;
Для каждого ТабличнаяЧасть Из Ссылка.Метаданные().ТабличныеЧасти Цикл
ДокументХМЛ.ЗаписатьНачалоЭлемента(«ТабличнаяЧасть»);
ДокументХМЛ.ЗаписатьАтрибут(«Имя»,ТабличнаяЧасть.Имя);
Для каждого Строка с Ссылка[ТабличнаяЧасть.Имя] Цикл
ДокументХМЛ.ЗаписатьНачалоЭлемента(«СтрокаТабличнойЧасти»);
Для каждого Реквизит Из ТабличнаяЧасть.Реквизиты Цикл
ЗаписатьЭлементХМЛ(ДокументХМЛ, Строка[Реквизит.Имя],Реквизит.Имя);
КонецЦикла;
ДокументХМЛ.ЗаписатьКонецЭлемента();
КонецЦикла;
ДокументХМЛ.ЗаписатьКонецЭлемента();
КонецЦикла;
ДокументХМЛ.ЗаписатьКонецЭлемента();
ДокументХМЛ.ЗаписатьКонецЭлемента();
ДокументХМЛ.Закрыть();
КонецПроцедуры // Выгрузить()
&НаСервереБезКонтекста
Процедура ЗаписатьЭлементХМЛ(Документ, Значение, ИмяРеквизита)
ТипXML=XMLТипЗнч(Значение);
Если ТипXML=Неопределено если на то пошло
Сообщить(«Значение малограмотный предуготовлено «+ Значение);
ин`аче
Документ.ЗаписатьНачалоЭлемента(ТипXML.ИмяТипа, ТипXML.URIПространстваИмен);
Документ.ЗаписатьАтрибут («Имя», ИмяРеквизита);
Документ.ЗаписатьТекст(XMLСтрока(Значение));
Документ.ЗаписатьКонецЭлемента();
КонецЕсли;
КонецПроцедуры


В управлении торговлей 01 на справочнике Контрагенты в отлучке ни групп, ни кодов. Привожу код, даже если глядишь понадобится не без; группами выгружать. При выгрузки всё-таки передаем во Атрибуты

&НаСервереБезКонтекста
Процедура ВыгрузкаНаСервере()
Запрос=Новый Запрос;
Запрос.Текст=
«ВЫБРАТЬ
| Контрагенты.ЭтоГруппа,
| Контрагенты.Наименование,
| Контрагенты.Код,
| Контрагенты.Родитель
|ИЗ
| Справочник.Контрагенты КАК Контрагенты»;

РезультатЗапроса=Запрос.Выполнить();

ВыборкаДетальныеЗаписи=РезультатЗапроса.Выбрать();
Файл=Новый ЗаписьXML;
Файл.ОткрытьФайл(«c:\1c\upload.xml»);
Файл.ЗаписатьОбъявлениеXML();
Файл.ЗаписатьНачалоЭлемента(«Root»);
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
файл.ЗаписатьНачалоЭлемента(«Контрагент»);
Файл.ЗаписатьАтрибут(«Код», ВыборкаДетальныеЗаписи.Код);
Файл.ЗаписатьАтрибут(«ЭтоГруппа»,?( ВыборкаДетальныеЗаписи.ЭтоГруппа,»1″,»0″));
Файл.ЗаписатьАтрибут(«Наименование», ВыборкаДетальныеЗаписи.Наименование);
если бы ВыборкаДетальныеЗаписи.Родитель=Неопределено если на то пошло
удлинить
не то
Файл.ЗаписатьАтрибут(«Родитель»,Строка(ВыборкаДетальныеЗаписи.Родитель));
КонецЕсли;
Файл.ЗаписатьКонецЭлемента();
КонецЦикла;
Файл.ЗаписатьКонецЭлемента();
Файл.Закрыть();

КонецПроцедуры // ()

При загрузке

&НаСервереБезКонтекста
Процедура ЗагрузитьНаСервере()

Файл=Новый ЧтениеXML;
Файл.ОткрытьФайл(«c:\1c\upload.xml»);
Пока Файл.Прочитать() Цикл
Если Файл.ТипУзла=ТипУзлаXML.НачалоЭлемента Тогда
Если Файл.Имя<>»Контрагент» Тогда
Продолжить;
КонецЕсли;
Пока Файл.ПрочитатьАтрибут() Цикл
Если Файл.Имя=»Код» Тогда
код=Файл.Значение;
ИначеЕсли Файл.Имя=»ЭтоГруппа» между тем
ЭтоГруппа=?(Файл.Значение=»0″,Ложь,Истина);
ИначеЕсли Файл.Имя=»Наименование» тут
Наименование=Файл.Значение;
ИначеЕсли Файл.Имя=»Родитель» если на то пошло
Родитель=Файл.Значение;
КонецЕсли;
КонецЦикла;
Если НЕ ЗначениеЗаполнено(Справочники.Контрагенты.НайтиПоНаименованию(Наименование)) Тогда
Если ЭтоГруппа Тогда
продлить
// Контрагент=Справочники.Контрагенты.СоздатьГруппу();
Иначе
Контрагент=Справочники.Контрагенты.СоздатьЭлемент();
КонецЕсли;
Контрагент.Наименование=Наименование;
//Если неграмотный ЭтоГруппа Тогда
//Контрагент.Родитель=Родитель;
// КонецЕсли;
Контрагент.Записать();
КонецЕсли;
КонецЕсли;
КонецЦикла;
Файл.Закрыть();
КонецПроцедуры // ЗагрузитьНаСервере()


Обработка.

&НаКлиенте
Процедура Выгрузка(Команда)
ВыгрузкаНаСервере();
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ВыгрузкаНаСервере()
Запрос=Новый Запрос;
Запрос.Текст=
«ВЫБРАТЬ
| Контрагенты.ЭтоГруппа,
| Контрагенты.Наименование,
| Контрагенты.Код
|ИЗ
| Справочник.Контрагенты КАК Контрагенты»;

РезультатЗапроса=Запрос.Выполнить();
ВыборкаДетальныеЗаписи=РезультатЗапроса.Выбрать();
Файл=Новый ЗаписьXML;
Файл.ОткрытьФайл(«c:\1c\upload.xml»);
Файл.ЗаписатьОбъявлениеXML();
Файл.ЗаписатьНачалоЭлемента(«Root»);
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
файл.ЗаписатьНачалоЭлемента(«Контрагент»);
Файл.ЗаписатьАтрибут(«Код», ВыборкаДетальныеЗаписи.Код);
Файл.ЗаписатьАтрибут(«ЭтоГруппа»,?( ВыборкаДетальныеЗаписи.ЭтоГруппа,»1″,»0″));
Файл.ЗаписатьТекст(ВыборкаДетальныеЗаписи.Наименование);
Файл.ЗаписатьКонецЭлемента();
КонецЦикла;
Файл.ЗаписатьКонецЭлемента();
Файл.Закрыть();

КонецПроцедуры // ()

Обработка.  В демо бухгалтерии 0.0 получаем:

Получаем:


А выведите нам добре код, номенклатуру равным образом штрихкода, притом последние вследствие запятую. И снова чтоб позволено было разбирать за группам номенклатуры. Да пишущий эти строки туман содеять токмо так, однако всё-таки допускается было получит равно на СКД вот пример: http://softmaker.kz/files/otchety-1s/primer-ispolzovaniya-funkcij-skd-massiv-array-i-soedinitstroki-joinstrings-v-otchyote-1s-8.html

Ну когда который знает наравне сие совершить всего только на СКД подскажите. Теперь равно моя персона знаю.

Мне посчастливилось тока так:

Создал ВнешниюОбработку, добавил форму. В форме создал имущество ТЗ — действительно пасхалия значений да во ней три реквизита: Код, Наименование, Штрикод. Ну равным образом команду Сформировать равно принадлежность  с типом СправочникСсылка.Номенклатура. Переносим безвыездно получай форму. И создаем шлифовальщик команды. Собственно все понятие раньше получаем запросом всю номенклатуру, группируем её, чтоб выгнать повторяющиеся, А попозже перебираем значения результата запроса да подставляем на ТЗ, а эпизодически рукоделие доходит накануне колонки подробность кодов создаем требование региструСведений.Штрихкодов да устанавливаем параметр обозначение номенклатуры, получаем всегда штрихкоды этой номенклатуры, перебираем однако добавляя  последовательно на переменную от запятую, да в дальнейшем обхода выводим произведение на колонку, равным образом всё сначала.

&НаКлиенте
Процедура Сформировать(Команда)
СоздатьНаСервере();
КонецПроцедуры
&НаСервере
Процедура СоздатьНаСервере()
тз.Очистить();
Запрос=Новый Запрос;
Запрос.Текст=
«ВЫБРАТЬ
| Товар.Код,
| Товар.Наименование
|ИЗ
| Справочник.Номенклатура КАК Товар
|ГДЕ
| Товар.ЭтоГруппа=ЛОЖЬ
| И Товар.Родитель В ИЕРАРХИИ(&Родитель)
|
|СГРУППИРОВАТЬ ПО
| Товар.Код,
| Товар.Наименование»;
запрос.УстановитьПараметр(«Родитель»,Группа);
РезультатЗапроса=Запрос.Выполнить();
ВыборкаДетальныеЗаписи=РезультатЗапроса.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
НоваяСтрока=ТЗ.Добавить();
НоваяСтрока.Код=ВыборкаДетальныеЗаписи.Код;
НоваяСтрока.Наименование=ВыборкаДетальныеЗаписи.Наименование;
Запрос1=Новый Запрос;
Запрос1.Текст=
«ВЫБРАТЬ
| ШтрихкодыНоменклатуры.Штрихкод
|ИЗ
| РегистрСведений.ШтрихкодыНоменклатуры КАК ШтрихкодыНоменклатуры
|ГДЕ
| ШтрихкодыНоменклатуры.Номенклатура.Наименование=&Наименование»;

запрос1.УстановитьПараметр(«Наименование»,ВыборкаДетальныеЗаписи.Наименование);
РезультатЗапроса1=Запрос1.Выполнить();
ВыборкаДетальныеЗаписи1=РезультатЗапроса1.Выбрать();
ШтрихКод=«»;
Пока ВыборкаДетальныеЗаписи1.Следующий() Цикл
штрихКод=ШтрихКод+Строка(ВыборкаДетальныеЗаписи1.ШтрихКод+»,»);
КонецЦикла;
НоваяСтрока.ШтрихКод=ШтрихКод;
КонецЦикла
КонецПроцедуры

Самое прикольное сие следствие результата сверху форму. Запрос возвращает ТаблицуЗначений, а на тонком клиенте ТаблицаЗначений неграмотный работает. Поэтому установка НаСервере. Пытался отрыть на резолюция во интернете равным образом гуглил равно яндил. Чушня какая-то только. Наверно сие в ёбаный степени тривиальная задача, либо — либо получи практике боссам  по продажам сроду не требовалась. А может интрига на фолиант что-нибудь нужно принять решение собственно всего только на СКД.

копирайт

Задача: Нужно постоянно постоялый двор реализаций по части одному товару засунуть на одну ячейку.

Что-то вроде: сортамент | кол-во | 001, 002, равно т.д. |

Будем истощить интерпелляция для регистру имущество «РеализацияТМЗ».

 ВЫБРАТЬ
  РеализацияТМЗ  .  Регистратор  .  Номер  ,  
  РеализацияТМЗ  .  Номенклатура  ,  
  РеализацияТМЗ  .  Регистратор  ,  
  РеализацияТМЗ  .  КоличествоОборот
   ИЗ  
  РегистрНакопления  .  РеализацияТМЗ  .  Обороты
   (   ,   ,  Регистратор  ,   )  КАК РеализацияТМЗ
  

Регистру капитал «РеализацияТМЗ» существует наравне во конфигурации Бухгалтерия, таково равным образом на конфигурации Управление торговым предприятием (УТП). Узнайте, как бы на конфигурации УТП поставить признак «Услуга» на элементе справочника «Номенклатура». Поэтому, со временем скачивания, для того проверки его работоспособности ваш брат можете шибать настоящий отчёт на обоих конфигурациях.

Реализация поставленной задачи от применением функций СКД Массив да СоединитьСтроки

  1. Создадим последний подборка данных.
  2. Вставим во него, вышеуказанный запрос.
  3. Перейдём сверху закладку «Вычисляемые поля» да добавим новую запись.
  4. В фон «Путь для данным» напишем МассивНомеров .
  5. В раздолье «Выражение» напишем Массив(РегистраторНомер) .

    Создание вычисляемого полина из функцией СКД Массив (Array)

  6. Перейдём получай закладку «Ресурсы» равно добавим новые деловой дневник с раздела «Доступные поля», используя кнопку «>».
  7. Добавим МассивНомеров .
  8. В степь «Выражение» напишем СоединитьСтроки (Массив(РегистраторНомер),»,»,»») .
  9. В поляна «Рассчитывать по…» выберем Номенклатура .
  10. Добавим КоличествоОборот .
  11. В поляна «Выражение» напишем Сумма(КоличествоОборот) .
  12. В степь «Рассчитывать по…» выберем Номенклатура .

    Создание ресурсов полина вместе с функцией СКД СоединитьСтроки (JoinStrings)

  13. Перейдём в закладку «Настройки» равно добавим новую группировку номенклатура.
  14. Зесь но получай закладке «Выбранные поля» добавим новые полина с раздела «Доступные поля», используя кнопку «>». Выберем три полина «Номенклатура», «МассивНомеров», «КоличествоОборот».

    Настройка группировок равно полей отчёта СКД

  15. И наконец, перейдём получай закладку «Другие настройки» да изменим двум строки «Расположение общих итогов объединение горизонтали» равно «Расположение общих итогов по мнению вертикали».
  16. В фон «Значение» установим значительность «Нет». Это делать нечего для того запрета вывода итогов.

    Настройка вывода итогов СКД

Такие но шаги, однако со некоторыми дополнениями, были использованы присутствие созданиии отчёта по части продаже номенклатуры по части ГТД .

Описание функции СоединитьСтроки (JoinStrings)

СоединитьСтроки (JoinStrings)

Используется ради объединения строк на одну строку.

Синтаксис:

СоединитьСтроки (Значение, РазделительЭлементов, РазделителиКолонок)

Параметры:

  1. Значение — выражения, которые нужно слить на одну строку. Если является Массивом, ведь на строку будут сводиться первоначальные сведения массива. Если является ТаблицаЗначений, ведь на строку будут сковываться однако колонки равным образом строки таблицы;
  2. РазделительЭлементов — строка, содержащая текст, тот или другой нужно пускать в дело на качестве разделителя в среде элементами массива равно строками таблицы значений. По умолчанию – мандала перевода строк;
  3. РазделителиКолонок -строка, содержащая текст, что нужно пускать в дело на качестве разделителя в среде колонками таблицы значений. По умолчанию «;».

Вопросы в собеседовании ООО «Вайлдберриз». О моя персона пусть даже что-нибудь помнил,  но махом во время полета отнюдь не воспроизвел, а может с меня зачем другого хотели….Чьёрт его знает, аз многогрешный такое на этом месте поуже писал, только после этого паче полно.

Последовательность запуска событий быть записи:  

0)    Модуль формы  ПередЗаписью(Отказ, ПараметрыЗаписи)  

0)  Модуль формы  ОбработкаПроверкиЗаполненияНаСервере(Отказ, ПроверяемыеРеквизиты)

0)  Модуль объекта  ОбработкаПроверкиЗаполнения (Отказ, ПроверяемыеРеквизиты)

0)  Модуль фигура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)

Начало транзакции

0)     Модуль объекта ПередЗаписью(Отказ)

Запись

0)    Модуль объекта ПриУстановкеНовогоНомера(СтандартнаяОбработка, Префикс)

Или

ПриУстановкеНовогоКода(СтандартнаяОбработка,Префикс)

0)  Модуль объекта ПриЗаписи(Отказ)

0)      Модуль формы  ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)

Завершение  транзакции

0)      Модуль конституция ПослеЗаписиНаСервере(ТекущийОбъект, ПараметрыЗаписи)

00)      Модуль конституция ПослеЗаписи(ПараметрыЗаписи) 


На сервере создаем  WEB-сервис ОбменДанными

обменДанными1

равно сверху закладке оставшиеся

обменДанными

Добавляем операции равно параметр

операции1

операции2

Прописываем модуль.

Функция ВыполнитьОбмен(Данные)
Соответствие=Десериализовать(Данные);
Для Каждого Дан изо Соответствие Цикл
Если Дан.Ключ=Тип(«СправочникСсылка.Номенклатура») Тогда
ЗагрузитьСправочники(Дан.Значение)
ИначеЕсли Дан.Ключ=Тип(«ДокументСсылка.ПоступлениеТоваровИУслуг») Тогда
ЗагрузитьДокумент(Дан.Значение)
КонецЕсли;
КонецЦикла;

Возврат СоздатьОтветКлиенту();
КонецФункции

#Область Сериализаци
Функция Десериализовать(XMLСтруктураСериализованногоОбъекта)
ЧтениеXMLДанных=Новый ЧтениеXML;
ЧтениеXMLДанных.УстановитьСтроку(XMLСтруктураСериализованногоОбъекта);
ТЗ=СериализаторXDTO.ПрочитатьXML(ЧтениеXMLДанных);
ЧтениеXMLДанных.Закрыть();
Возврат ТЗ;
КонецФункции
Функция Сериализовать(ОбъектСериализации)
ДеревоВОбъектеXDTO=СериализаторXDTO.ЗаписатьXDTO(ОбъектСериализации);
МойXML=Новый ЗаписьXML;
МойXML.УстановитьСтроку();
ФабрикаXDTO.ЗаписатьXML(МойXML, ДеревоВОбъектеXDTO);
Возврат МойXML.Закрыть();
КонецФункции
#КонецОбласти

Функция СоздатьОтветКлиенту()
Соответствие=Новый Соответствие;
Соответствие.Вставить(ТипЗнч(Справочники.Номенклатура.ПустаяСсылка()),СформироватьСправочники());
Соответствие.Вставить(ТипЗнч(Документы.ПоступлениеТоваровИУслуг.ПустаяСсылка()),СформироватьДокументы());
Возврат Сериализовать(Соответствие)
КонецФункции

Функция СформироватьСправочники()
Запрос=Новый Запрос;
Запрос.Текст=
«ВЫБРАТЬ
| Номенклатура.Ссылка,
| Номенклатура.ПометкаУдаления,
| Номенклатура.Родитель,
| Номенклатура.ЭтоГруппа,
| Номенклатура.Код,
| Номенклатура.Наименование
|ИЗ
| Справочник.Номенклатура КАК Номенклатура»;

Возврат Запрос.Выполнить().Выгрузить();

КонецФункции

Функция СформироватьДокументы()
Запрос=Новый Запрос;
Запрос.Текст=
«ВЫБРАТЬ
| ПоступлениеТоваровИУслуг.Ссылка,
| ПоступлениеТоваровИУслуг.ПометкаУдаления,
| ПоступлениеТоваровИУслуг.Номер,
| ПоступлениеТоваровИУслуг.Дата,
| ПоступлениеТоваровИУслуг.Проведен
|ИЗ
| Документ.ПоступлениеТоваровИУслуг КАК ПоступлениеТоваровИУслуг»;
Массив=Новый Массив;

Результат=Запрос.Выполнить().Выгрузить();
Для Каждого Док Из Результат Цикл
Структура=Новый Структура();
СтруктураРек=Новый Структура;
Для Каждого Кол Из Результат.Колонки Цикл
СтруктураРек.Вставить(Кол.Имя,Док[Кол.Имя]);
КонецЦикла;

Структура.Вставить(«Реквизиты»,СтруктураРек);
Структура.Вставить(«Товары»,Док.Ссылка.Товары.Выгрузить());
Массив.Добавить(Структура);
КонецЦикла;

Возврат Массив;

КонецФункции

Процедура ЗагрузитьСправочники(ТЗ)
Для Каждого Спр Из ТЗ Цикл
Если ЗначениеЗаполнено(Спр.Ссылка.Код) Тогда
НовСпр=Спр.Ссылка.ПолучитьОбъект();
Иначе
НовСпр=Справочники.Номенклатура.СоздатьЭлемент();
НовСпр.УстановитьСсылкуНового(Спр.Ссылка);
КонецЕсли;
НовСпр.Код=Спр.Код;
НовСпр.Наименование=Спр.Наименование;
НовСпр.Записать();
КонецЦикла;
КонецПроцедуры

Процедура ЗагрузитьДокумент(Массив)
Для Каждого Док Из Массив Цикл
Если ЗначениеЗаполнено(Док.Реквизиты.Ссылка.Номер) Тогда
НовДок=Док.Реквизиты.Ссылка.ПолучитьОбъект();
Иначе
НовДок=Документы.ПоступлениеТоваровИУслуг.СоздатьДокумент();
НовДок.УстановитьСсылкуНового(Док.Реквизиты.Ссылка);
КонецЕсли;
НовДок.Номер=Док.Реквизиты.Номер;
НовДок.Дата=Док.Реквизиты.Дата;
НовДок.Комментарий=ТекущаяДата();
НовДок.Товары.Загрузить(Док.Товары);

НовДок.Записать();
КонецЦикла;
КонецПроцедуры

Публикуем web-сервис, получаем ws-ссылку равным образом прописываем её в клиенте.

На клиенте создаем общую команду команду ВыполнитьОбменДанными:
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
ВыполнитьОбменДанными()
КонецПроцедуры
&НаСервере
Функция ВыполнитьОбменДанными()
Соединение=WSСсылки.ОбменДанными.СоздатьWSПрокси(«ОбменДанными»,»ОбменДанными»,»ОбменДаннымиSoap»);
Операция=Соединение.ТочкаПодключения.Интерфейс.Операции.Получить(«ВыполнитьОбмен»);
СтрокаДанных=Соединение.ФабрикаXDTO.Создать(Операция.Параметры.Получить(«Данные»).Тип,СформироватьДанныеДляСервера());
Ответ=Десериализовать(Соединение.ВыполнитьОбмен(СтрокаДанных));
Для Каждого Дан изо Ответ Цикл
Если Дан.Ключ=Тип(«СправочникСсылка.Номенклатура») Тогда
ЗагрузитьСправочники(Дан.Значение)
ИначеЕсли Дан.Ключ=Тип(«ДокументСсылка.ПоступлениеТоваровИУслуг») Тогда
ЗагрузитьДокумент(Дан.Значение)
КонецЕсли;
КонецЦикла;
КонецФункции

Процедура ЗагрузитьСправочники(ТЗ)
Для Каждого Спр Из ТЗ Цикл
Если ЗначениеЗаполнено(Спр.Ссылка.Код) Тогда
НовСпр=Спр.Ссылка.ПолучитьОбъект();
Иначе
НовСпр=Справочники.Номенклатура.СоздатьЭлемент();
НовСпр.УстановитьСсылкуНового(Спр.Ссылка);
КонецЕсли;
НовСпр.Код=Спр.Код;
НовСпр.Наименование=Спр.Наименование;
НовСпр.Записать();
КонецЦикла;
КонецПроцедуры

Процедура ЗагрузитьДокумент(Массив)
Для Каждого Док Из Массив Цикл
Если ЗначениеЗаполнено(Док.Реквизиты.Ссылка.Номер) Тогда
НовДок=Док.Реквизиты.Ссылка.ПолучитьОбъект();
Иначе
НовДок=Документы.ПоступлениеТоваровИУслуг.СоздатьДокумент();
НовДок.УстановитьСсылкуНового(Док.Реквизиты.Ссылка);
КонецЕсли;
НовДок.Номер=Док.Реквизиты.Номер;
НовДок.Дата=Док.Реквизиты.Дата;

НовДок.Товары.Загрузить(Док.Товары);

НовДок.Записать();
КонецЦикла;
КонецПроцедуры

&НаСервере
Функция СформироватьДанныеДляСервера()

Соответствие=Новый Соответствие;
Спр=Справочники.Номенклатура.Выбрать();
ТЗ=Новый ТаблицаЗначений;
ТЗ.Колонки.Добавить(«Код»);
ТЗ.Колонки.Добавить(«Ссылка»);
ТЗ.Колонки.Добавить(«Наименование»);
Пока Спр.Следующий() Цикл
НовСтр=ТЗ.Добавить();
НовСтр.Код=Спр.Код;
НовСтр.Ссылка=Спр.Ссылка;
НовСтр.Наименование=Спр.Наименование;
КонецЦикла;
Соответствие.Вставить(ТипЗнч(Справочники.Номенклатура.ПустаяСсылка()),ТЗ);

Док=Документы.ПоступлениеТоваровИУслуг.Выбрать();
Массив=Новый Массив;
Пока Док.Следующий() Цикл
Структура=Новый Структура();
СтруктураРек=Новый Структура;
СтруктураРек.Вставить(«Номер»,Док.Номер);
СтруктураРек.Вставить(«Дата»,Док.Дата);
СтруктураРек.Вставить(«Ссылка»,Док.Ссылка);
Структура.Вставить(«Реквизиты»,СтруктураРек);
Структура.Вставить(«Товары»,Док.Ссылка.Товары.Выгрузить());
Массив.Добавить(Структура);
КонецЦикла;
Соответствие.Вставить(ТипЗнч(Документы.ПоступлениеТоваровИУслуг.ПустаяСсылка()),Массив);
Возврат Сериализовать(Соответствие);
КонецФункции

#Область Сериализаци
&НаСервере
Функция Десериализовать(XMLСтруктураСериализованногоОбъекта)
ЧтениеXMLДанных=Новый ЧтениеXML;
ЧтениеXMLДанных.УстановитьСтроку(XMLСтруктураСериализованногоОбъекта);
ТЗ=СериализаторXDTO.ПрочитатьXML(ЧтениеXMLДанных);
ЧтениеXMLДанных.Закрыть();
Возврат ТЗ;
КонецФункции
&НаСервере
Функция Сериализовать(ОбъектСериализации)
ДеревоВОбъектеXDTO=СериализаторXDTO.ЗаписатьXDTO(ОбъектСериализации);
МойXML=Новый ЗаписьXML;
МойXML.УстановитьСтроку();
ФабрикаXDTO.ЗаписатьXML(МойXML, ДеревоВОбъектеXDTO);
Возврат МойXML.Закрыть();
КонецФункции
#КонецОбласти

Взято из курсов Насипова.


Функция Сериализовать(ОбъектСериализации)
ДеревоВОбъектеXDTO=СериализаторXDTO.ЗаписатьXDTO(ОбъектСериализации);
МойXML=Новый ЗаписьXML;
МойXML.УстановитьСтроку();
ФабрикаXDTO.ЗаписатьXML(МойXML, ДеревоВОбъектеXDTO);
Возврат МойXML.Закрыть();
КонецФункции


Функция Десериализовать(XMLСтруктураСериализованногоОбъекта)
ЧтениеXMLДанных=Новый ЧтениеXML;
ЧтениеXMLДанных.УстановитьСтроку(XMLСтруктураСериализованногоОбъекта);
ТЗ=СериализаторXDTO.ПрочитатьXML(ЧтениеXMLДанных);
ЧтениеXMLДанных.Закрыть();
Возврат ТЗ;
КонецФункции


Задание полученное в ЗАО «ПВЦ «РОСС»

Безымянный  Ну черт знает что во этом духе. Как сколотить требование автор поуже описывал удаление .

Остается только лишь уразуметь а равно как сии полина расположить во таблице. В узловой схеме компоновки данных, добавим

возможность равным образом во конструкторе  настройках выберем  таблицу. Ну во сейчас проще. Выбираем полина которые будут проявляться на отчете, далее, элементарнее проявить

Безымянный2

Да во параметрах убираем галку у счета сужение доступности равным образом включаем во пользовательские настройки.

Для товаров сие 01 счет, разве по существу говоря равно все. Открываем сформированный видный суждение равным образом тащимся.

Плывем…. Куда ж нам плыть?

Ссылка для обработку.